Floppy drive issues - SOLVED

Problems with your machine in general.
Post Reply
ultros
Posts: 3
Joined: Fri May 11, 2018 12:56 am

Floppy drive issues - SOLVED

Post by ultros »

Hi,

I hope my English speaking will be good enough. I'm a newbie here but it is a pleasure to see such a nice website where the ST is not dead. ;)
I have a 520STE with 4MB ram and love using Maxymiser tracker.
But the floppy drive is now dead and can't read any disk. So I finally found Exxos store while searching for a new one.
Here is my question, do I need to upgrade my STE with HDV6 in order to use a ALPS 1.44/720k FLOPPY DRIVE REFURB actually available?

Many thanks in advance.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy drive issues

Post by exxos »

Have you tried cleaning the drive heads ? https://www.exxosforum.co.uk/forum/viewt ... ?f=17&t=96

Floppy drives and also failed if the PSU is going bad.

You can use the drives in my store, don't need the HD6 kit unless you are wanting to use 1.44 floppys.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
ultros
Posts: 3
Joined: Fri May 11, 2018 12:56 am

Re: Floppy drive issues

Post by ultros »

Hi Exxos,
Many thanks for your reply.
Yes I've tried but not as deep as described in your topic.
I'm gonna follow your advice and try a deeper cleaning.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10865
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Floppy drive issues

Post by rubber_jonnie »

Have you considered moving from floppy to Gotek?
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
Petari
Posts: 408
Joined: Tue Nov 28, 2017 1:32 pm

Re: Floppy drive issues

Post by Petari »

Or maybe HxC ? Hey rubber_jonnie - any success with 2MB images on Gotek ? I asking because not sure is it possible with Gotek. With HxC is, for sure.
There is 2 kind of people: one thinking about moving to Mars after here becomes too bad, the others thinking about how to keep this planet habitable.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10865
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Floppy drive issues

Post by rubber_jonnie »

I did post in the other topic, it doesn't work with FlashFloppy, and I just haven't had time to try with HxC firmware. As soon as I try, I will post, but I need to flash one of my Goteks first. Hopefully I will be able to try this weekend if all goes to plan!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
ultros
Posts: 3
Joined: Fri May 11, 2018 12:56 am

Re: Floppy drive issues

Post by ultros »

Hi. Many thanks for your advices, I didn't know the Gotek system or HxC, I guess it will be the next project. But for the moment, the deeper cleaning of the floppy drive with IPA pads is a success. Thanks again.
Post Reply

Return to “HARDWARE ISSUES”