Fixing up my MEGA STE

Problems with your machine in general.
User avatar
Bikerbob
Posts: 506
Joined: Fri Nov 10, 2017 7:30 pm
Location: Mississauga, ON
Contact:

Fixing up my MEGA STE

Post by Bikerbob »

Hey all,

Looking for a hand on some stuff.

New to me Mega STE - couple of issues right off I want to fix.

I have one of the ram sockets with a broken retainer. Is it a single socket double? how to replace them?

I would like to put the FPU in. Is that just a matter of the chip and a jumper? I see matching chip # on ebay. Just wondering if I buy.

I am going to use the PP program to divide my rom image in 2 to burn on my willem.

Any suggestions? - OH I do want a PSU cap set.. maybe 2. I will order that on the store page.

James
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Fixing up my MEGA STE

Post by Icky »

Hi Bikerbob.

For the FPU it’s not as simple as just putting the chip in. You also need to add a GAL chip and there is either a jumper or if your MegaSTE is like mine an older one cutting off a resistor underneath the motherboard.

I found my GAL on eBay and I purchased the 68882 and 68881 as I wanted to try out both from Exxos’ store.

Here is a link to a blog guide http://gtello.pagesperso-orange.fr/mste_e.htm

You can fit either a 68881 or 68882. Some programs may not work with the 68882.

Edit:

Here is the official instructions from Atari http://www.atariworld.org/files/docs/C3 ... -REV-A.pdf
User avatar
Bikerbob
Posts: 506
Joined: Fri Nov 10, 2017 7:30 pm
Location: Mississauga, ON
Contact:

Re: Fixing up my MEGA STE

Post by Bikerbob »

Icky wrote: Thu Nov 16, 2017 8:07 am Hi Bikerbob.

For the FPU it’s not as simple as just putting the chip in. You also need to add a GAL chip and there is either a jumper or if your MegaSTE is like mine an older one cutting off a resistor underneath the motherboard.

I found my GAL on eBay and I purchased the 68882 and 68881 as I wanted to try out both from Exxos’ store.

Here is a link to a blog guide http://gtello.pagesperso-orange.fr/mste_e.htm

You can fit either a 68881 or 68882. Some programs may not work with the 68882.

Edit:

Here is the official instructions from Atari http://www.atariworld.org/files/docs/C3 ... -REV-A.pdf
Thanks for the reply Icky, so the gal is like this? https://www.ebay.ca/itm/5PCS-IC-GAL16V8 ... Sw6EhUN1OR

what did you do? the 68881 or 2? they say the 8882 is improved? I am not going to be doing specific scientific work ;) so .. just looking for improved performance.

James
User avatar
Maeke
Posts: 260
Joined: Thu Aug 17, 2017 3:09 pm

Re: Fixing up my MEGA STE

Post by Maeke »

Bikerbob wrote: Thu Nov 16, 2017 9:35 pm
Icky wrote: Thu Nov 16, 2017 8:07 am Hi Bikerbob.

For the FPU it’s not as simple as just putting the chip in. You also need to add a GAL chip and there is either a jumper or if your MegaSTE is like mine an older one cutting off a resistor underneath the motherboard.

I found my GAL on eBay and I purchased the 68882 and 68881 as I wanted to try out both from Exxos’ store.

Here is a link to a blog guide http://gtello.pagesperso-orange.fr/mste_e.htm

You can fit either a 68881 or 68882. Some programs may not work with the 68882.

Edit:

Here is the official instructions from Atari http://www.atariworld.org/files/docs/C3 ... -REV-A.pdf
Thanks for the reply Icky, so the gal is like this? https://www.ebay.ca/itm/5PCS-IC-GAL16V8 ... Sw6EhUN1OR

what did you do? the 68881 or 2? they say the 8882 is improved? I am not going to be doing specific scientific work ;) so .. just looking for improved performance.

James
You can find preprogrammed gal on ebay, or complete kits. Can't give you a link sorry since i'll have only french links.
If i take too long to reply, sorry my cat is sleeping on my laps.
User avatar
Bikerbob
Posts: 506
Joined: Fri Nov 10, 2017 7:30 pm
Location: Mississauga, ON
Contact:

Re: Fixing up my MEGA STE

Post by Bikerbob »

OK, so I will need a gal for the FPU,

There is a gal in the VME board I am buying.

I also think there are some Gal chips I need to program in an-8bit project im doing.

Do all these things use the same chip? or are there 20pin 24pin 28pin gal chips used?

BUT I dont think my Willem programmer does GAL chips.

James
User avatar
Bikerbob
Posts: 506
Joined: Fri Nov 10, 2017 7:30 pm
Location: Mississauga, ON
Contact:

Re: Fixing up my MEGA STE

Post by Bikerbob »

Hope someone is reading.

I would like to get a co-procoessor and the GAL chip required. I can get the co-pro easy enough on ebay.

I am not finding any GAL chips there.

Is there other updates that would require GAL programming? I could buy a programmer, but think $50 for something I am going to do once seems silly.

James
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Fixing up my MEGA STE

Post by exxos »

I don't know about MSTE myself, but I can program a GAL if thats all you need. Though I would need the jed file..
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Fixing up my MEGA STE

Post by Icky »

exxos wrote: Wed Nov 22, 2017 4:09 pm I don't know about MSTE myself, but I can program a GAL if thats all you need. Though I would need the jed file..
You will need PAL C301903

Dump flies can be found here http://www.atari-forum.com/viewtopic.php?t=5040
User avatar
Bikerbob
Posts: 506
Joined: Fri Nov 10, 2017 7:30 pm
Location: Mississauga, ON
Contact:

Re: Fixing up my MEGA STE

Post by Bikerbob »

exxos wrote: Wed Nov 22, 2017 4:09 pm I don't know about MSTE myself, but I can program a GAL if thats all you need. Though I would need the jed file..

Ok, so when do you think you will have more of https://www.exxosforum.co.uk/atari/store2/#0107 in stock???

I will get one and the GAL programmed if I could. I already had the file, but Icky just linked to it as well.

James
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Fixing up my MEGA STE

Post by exxos »

Bikerbob wrote: Wed Nov 22, 2017 11:13 pm Ok, so when do you think you will have more of https://www.exxosforum.co.uk/atari/store2/#0107 in stock???
I don't know, Urban isn't making anymore. He is doing a "exxos" revision so I can produce them.. as to when.. no idea.. probably couple of months time or so I guess. Though I may dish out some kits meanwhile as I just don't have any free time to assemble lots of stuff.
Bikerbob wrote: Wed Nov 22, 2017 11:13 pm I will get one and the GAL programmed if I could. I already had the file, but Icky just linked to it as well.
Post the file here for easy to find and future reference..
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “HARDWARE ISSUES”