STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Blogs & guides and tales of woo by forum members.
PeteW
Posts: 99
Joined: Wed Jul 25, 2018 8:09 pm

STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW »

I have just received my 4meg ram upgrade from Chris. I decided to go with this one as I like how neat it is once installed.

https://www.exxosforum.co.uk/atari/store2/#0020

I'm working from home today, so at lunchtime I decided to start desoldering the existing ram chips from the motherboard:
20180727_174835.jpg
20180727_174835.jpg (4.3 MiB) Viewed 5990 times
So far it's been pretty easy. The ST motherboards seem to be good quality and cope with the heat from desoldering pretty well. I'd say the key to it is not rush and do it one chip at a time. I'm a vaguely competent solderer but by no means professional, however in my experience so far, to desolder chips without butchering them or the board, some basic rules are worth following:

1. Resolder the chip before you desolder it. It sounds counter intuitive and I don't know why, but new solder is easier to remove than old solder

2. Use a solder sucker twice per pin. If the solder still remains, add more solder and start again

3. Make sure that the hole is clear of solder top and bottom

4. Remove solder from the top of the board using solder wick. If that doesn't work, flip the board over, add more solder and start all over again

5. When the holes are clear, you might still need to apply a very small amount of leverage to the chip to get it to move, but not much

Anyone got any extra or better rules?!
User avatar
exxos
Site Admin
Site Admin
Posts: 24080
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by exxos »

PeteW wrote: Fri Jul 27, 2018 6:10 pm Anyone got any extra or better rules?!
Cut the pins first, a lot easier... like I did in my video...


https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
PeteW
Posts: 99
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW »

Thanks Chris that's really useful. I don't own any side cutters but it looks like I probably should!
troed
Moderator
Moderator
Posts: 912
Joined: Mon Aug 21, 2017 10:27 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by troed »

I used a hot air station, boiled the solder topside, pulled the chips out one by one with a plier - and all chips still worked afterwards and have been used for subsequent 520ST piggyback RAM upgrades.

But yes, you "shouldn't" hot air through-hole etc, but in my experience the ST motherboards can handle a lot of abuse ... I cleaned up the holes with solder wick afterwards.
PeteW
Posts: 99
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW »

I'm halfway through and have managed to get 8 out so far - hopefully they all still work :)

Because my motherboard is a 520 st, I need to put resistors in r71-73. I understand they're supposed to be 68r, but I only have 47 and 120. Will either of those do the job or shall I order myself a few 68s. They're not expensive, just take time to arrive.
troed
Moderator
Moderator
Posts: 912
Joined: Mon Aug 21, 2017 10:27 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by troed »

PeteW wrote: Sat Jul 28, 2018 9:18 am I'm halfway through and have managed to get 8 out so far - hopefully they all still work :)

Because my motherboard is a 520 st, I need to put resistors in r71-73. I understand they're supposed to be 68r, but I only have 47 and 120. Will either of those do the job or shall I order myself a few 68s. They're not expensive, just take time to arrive.
I've seen both 33 and 68Ohm resistors used, can't imagine you'd have any issues with 47.
User avatar
exxos
Site Admin
Site Admin
Posts: 24080
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by exxos »

47R should be fine. I use 33R in my 4 MB MMU kit , higher value resistors won't work in that case as the DRAM are 50ns or 60ns. 68R is "to slow" for the DRAM. But in case of 70ns or higher it doesn't really matter.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Atarian Computing
Posts: 445
Joined: Tue Aug 22, 2017 4:27 am

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by Atarian Computing »

troed wrote: Sat Jul 28, 2018 8:24 am I used a hot air station, boiled the solder topside, pulled the chips out one by one with a plier - and all chips still worked afterwards and have been used for subsequent 520ST piggyback RAM upgrades.

But yes, you "shouldn't" hot air through-hole etc, but in my experience the ST motherboards can handle a lot of abuse ... I cleaned up the holes with solder wick afterwards.
I do this as well when I need to use the extracted chip. Never had issues.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10863
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by rubber_jonnie »

exxos wrote: Sat Jul 28, 2018 9:57 am 47R should be fine. I use 33R in my 4 MB MMU kit , higher value resistors won't work in that case as the DRAM are 50ns or 60ns. 68R is "to slow" for the DRAM. But in case of 70ns or higher it doesn't really matter.
Hmm, interesting, I used 33R resistors in my first upgrade to 1MB on a C070789 mainboard, and it worked fine, but I changed to 68R for later boards, I had all sorts of trouble, wondering if a swap to 33R might help, and it's an easy job to do.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
PeteW
Posts: 99
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW »

Next question. I've removed C49 (blue capacitor on the right hand side of the Ram on the motherboard)

My motherboard is slightly different to the one in the 'how to' guide. Can someone confirm that where I've indicated in red is where I should reposition it to? Continuity tester appears to say yes, but I'd like a second opinion :)

Apologies for the pic - taken and edited on my phone!
Attachments
20180729_142014.jpg
20180729_142014.jpg (6.55 MiB) Viewed 5799 times
Post Reply

Return to “MEMBER BLOGS”