EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

IDE, ACSI etc kits and products.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by exxos »

IMG_4954.JPG
IMG_4954.JPG (349.77 KiB) Viewed 8368 times

First of all, huge thanks to everyone in the community who brought this project to life. Also extra thanks to @Icky for saving me the literal pain of designing the original board.

The development thread is as below.
https://www.exxosforum.co.uk/forum/viewt ... =73&t=1640


FEATURES OF THE V1.1 Version R1C
  • H4 & original ST/F/M compatibility.
  • ROM socket to hold DUALTOS TOS206 and TOS104 etc selected by jumper link.
  • Works with later versions of HDDriver 8.xx to 11.xx etc
  • IDE Active LED.
  • Wide range of support from CF adaptors, SD adaptors and old brick IDE HDD's.
  • Optional though 68K socket.
  • Buffered signals if using long IDE cables.
  • Brand new hardware and firmware built from the ground up. We didn't copy any existing designs, this is 100% all our own work.
  • Tested by @PhilC our break it expert.
  • Supports HD11's blitter speed up options for a speed boost of around 10%.

Preliminary parts list ( this is not yet final and may change)

parts_list.txt
(4.15 KiB) Downloaded 346 times

It is worth noting that with this revision you can fit some resistor packs such as THESE Or as in my image above, I simply used regular resistors. The resistor packs will likely look neater and easier to solder, but are a lot more expensive, so it is up to the builder to decide which ones to use.


FITTING OPTIONS

In both cases it requires a jumper wire to the ACSI port Pin 10.

H4 motherboards
- As shown in the above image, a 68K socket & CPU is not fitted or required for the H4 motherboards.

- ROM & PLCC44 socket are not required on the IDE board if using the H4 ROM, But will require a link from the IDE board to the H4 JP13 JUMPER left pin (remove jumper) .

ROM_CE.JPG
ROM_CE.JPG (28.83 KiB) Viewed 8355 times

Alternatively the H4 ROM can be removed and the ROM fitted to the IDE board instead.


STF motherboards.
The CPU must be removed from the motherboard and fitted to the IDE board. Then the IDE board fitted to the motherboard. ROM should be used on the IDE board.


FIXES & BODGE WIRES & OTHER INFO

The header strips for the "IO port" and JTAG connector are not needed to be fitted. The PLD's are supplied programmed, and I/O port is currently only used for development and debugging and has no use generally.

If using a ribbon cable, the corner of the connector must be filed little as it catches the edge of the ROM socket. as such I would recommend fitting some right angle header pins.

Do not use any other buffer chips other than the 74LS245. While other chips may well work, the LS series offer really good noise immunity , so trying to fit faster chips etc is not a good idea.

WARNING
If fitting on the H4, Be careful the IDE connector does not short out on the DMA chip pins, assuming you have DMA fitted into a socket.


Wires below are needed for those who purchased the R1C kit from my store.

IMG_4962.JPG
IMG_4962.JPG (272.57 KiB) Viewed 8293 times


LED's

The right-hand LED is the IDE drive itselfs "active" LED. This is the same signal as normally driving the LEDs on CF adapters.

A optional LED can be wired to pin 1 of the IO port. Positive/long lead to pin one, and short lead to 0v somewhere. This LED is more of a "interface active" LED. It may be useful for debugging purposes. As if the interface LED is on, but the IDE active LED is not on, then likely there is a problem connection on the CF connector or cable etc.

IMG_4958.JPG
IMG_4958.JPG (110.32 KiB) Viewed 8300 times


STORE LINK
https://www.exxosforum.co.uk/atari/store2/#0171
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by JezC »

Hi @exxos @rubber_jonnie - do either of you (or any other builder of these IDE interfaces) have a final parts list for the H4 build (and ideally with a supplier part number for the bits)?

I'm starting to plan my next order of bits (hopefully the last few shortages ready for my first H4 build) & thought it might be worth seeing which parts fro his IDE I can afford at the same time...

I know there are still a few options with ROM location etc. but I'll probably start with the ROM in the H4 socket.

Hoping that there is enough left in the kitty to get both sets of bits ordered :roll:
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by exxos »

I don't think anyone has done a parts list with actual order code. I generally have all this stuff in stock from very supplies as for years so is nothing I need to do.. It is also the reason the kit is sold cheaply as I don't have to do work such as looking for part numbers ;)
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by rubber_jonnie »

I don't specifically have a parts list @JezC .

I just go by the BoMs, I can have a look, see if I have annotated any, but I seem to recall the BoM for the H4 had a load of links in it.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by JezC »

Yes, that's pretty much what I was expecting...and many of the parts are reasonably standard, so little problem with much of the BOM.

I guess the two I'm least clear about are the socket for the PLD and what people would recommend for a right-angle IDE header/pins (so it doesn't catch on anything).

Fully understand and approve of you keeping your valuable/scarce time free for more entertaining pursuits! :thumbup:
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by JezC »

rubber_jonnie wrote: Mon May 18, 2020 12:29 pm I don't specifically have a parts list @JezC .

I just go by the BoMs, I can have a look, see if I have annotated any, but I seem to recall the BoM for the H4 had a load of links in it.
@rubber_jonnie fair enough, there are just a couple that are unique to this IDE board that I'm not sure of...might be that @Icky or @PhilC knows the parts if not.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by rubber_jonnie »

JezC wrote: Mon May 18, 2020 1:12 pm Yes, that's pretty much what I was expecting...and many of the parts are reasonably standard, so little problem with much of the BOM.

I guess the two I'm least clear about are the socket for the PLD and what people would recommend for a right-angle IDE header/pins (so it doesn't catch on anything).

Fully understand and approve of you keeping your valuable/scarce time free for more entertaining pursuits! :thumbup:
If you go for vertical headers, you will need to trim (Or melt and trim as I did) the large PLD socket. I'd recommend you go for right angle IDE pins. I did on one of mine and it's definitely the way to go.

The last batch of sockets I got were 3M, but I couldn't tell you the part number as I just ordered them by pin count.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by JezC »

rubber_jonnie wrote: Mon May 18, 2020 1:21 pm If you go for vertical headers, you will need to trim (Or melt and trim as I did) the large PLD socket. I'd recommend you go for right angle IDE pins. I did on one of mine and it's definitely the way to go.

The last batch of sockets I got were 3M, but I couldn't tell you the part number as I just ordered them by pin count.
@rubber_jonnie Ok - even knowing it's 3M should make the search a lot simpler - thanks for that.
Yes, I think the right-angled connector looks the best option.

Next trick is to sort out some power source for the IDE device (and 40 pin + power or 44 pin) :roll:
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by rubber_jonnie »

JezC wrote: Mon May 18, 2020 1:31 pm
Next trick is to sort out some power source for the IDE device (and 40 pin + power or 44 pin) :roll:
Bear in mind that the IDE connector is 44 pin. It will work with laptop hard drives and CF is also fine, I have both types in my Megas. If you're going to use a 40 pin IDE device you'll need a 44 pin to 40 pin adaptor, which didn't work great when I tried, plus you're looking at additional power load. Not a problem with 44 pin devices.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: EXXOS IDE V1.1 R1C BUILD & INSTALL INFORMATION

Post by JezC »

Yes, would definitely prefer to use a 44 pin device if I can...I might have a 2.5" laptop HDD to use (my CF card is destined to go into the Falcon at some point).

I'd better check if I need a cable as well (and maybe a second CF card adapter at some point)...
Post Reply

Return to “HARD DRIVES”