Gasteiner Atari Hard Drive fix - (floppy errors)

The latest tweaks and fixes to keep your machine running in tip-top shape.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 23677
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Gasteiner Atari Hard Drive fix - (floppy errors)

Post by exxos »

While ago I put up for sale a Gasteiner hard drive and it all tested out perfectly well. The problem was that some reason prevented the floppy drive working at all. Each time the hard drive was plugged floppy drive worked perfectly. I tried the floppy drive on another machine and it was fine. I also tried a few other floppy drives this problematic STE to no avail.

I found the fix for this seemed to be lifting up DMA pin 38 (RDY Signal) and feeding around 100R resistor in series with the pin to the motherboard.

The easiest thing I found to do this all topside. Then the DMA pin 38 upwards so they no longer contact the motherboard, solder a 100R resistor (or 2x50R in series like I did) and solder it to the top side of R303.

This seemed to fix the problem totally floppy drive no longer malfunctions with the hard drive connected.

I posted this fix here is a maybe relevant to other hard drives as well. The courses is very much a new problem and a WIP fix for it.

HDDFIX.JPG
HDDFIX.JPG (1.14 MiB) Viewed 4294 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 23677
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Gasteiner Atari Hard Drive fix - (floppy errors)

Post by exxos »

UPDATE.

I am classing this fix as possibly obsolete, as such errors seem to be relating to lack of pull ups on the DMA databus..

See this thread https://www.exxosforum.co.uk/forum/viewt ... =17&t=1417
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Locked

Return to “TWEAKS & FIXES”