CURRENT PROTOTYPE STATUS (SEC 64MHz 68000)

Information and news about the 68SEC000 64MHz booster.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos »

@PhilC Once you done this https://www.exxosforum.co.uk/forum/viewt ... 893#p31893 and you get your SEC booster running (ask @Icky for images how to fit it to the H4 ;) ) See if ultrasatan and the floppy drive behave. Icky can't get ultrasatan working correctly with the SEC installed. Though its all currently working fine on my STFM here.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC »

@exxos will do. Will start with a good STFM and once that works, move on to the H4.
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by Icky »

After discussing with @exxos it seemed to be the Blitter causing the issue. After removing Blitter the floppy and UltraSATAN works together. However am still having issues with Gigafile.

@PhilC - just go straight for the H4. It’s a very easy install.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC »

Icky wrote: Wed Jan 15, 2020 7:18 am After discussing with @exxos it seemed to be the Blitter causing the issue. After removing Blitter the floppy and UltraSATAN works together. However am still having issues with Gigafile.

@PhilC - just go straight for the H4. It’s a very easy install.
Will do @Icky
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos »

It be interesting what speed you get with tos206 with glitter as I've still got slower than expected speeds on my stfm. I get 175% first test but the ste is 181% but as ROM is faster on the sec the speeds should be more like 190%.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos »

Been doing a lot of tweaks. Getting TOS104, TOS206, BLITTER, ULTRASATAN all to play nice is a nightmare.

Mostly , for some odd reason, TOS104 I need to wait for ST_DTACK to go high before allowing any ROM decoding to happen. TOS206 doesn't seem to care.. Without that sync delay, TOS104 resets when accessing C: drive, TOS206 doesn't. ROM speed has dropped a bit, but still at 309%. First GB6 test has dropped from 172% to 163%... will fiddle more tomorrow.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos »

This isn't a very exciting test.. But I kept reducing the DTACK pull up (about 434R now!) To see what would happen, and the figures have gone up ever so slightly..

dt.jpg
dt.jpg (153.27 KiB) Viewed 3371 times

I think what the problem is in terms of ROM speed access, is that because ST_DTACK is so slow, I have to wait for it to go high before I let the CPU read DTACK as issued by the PLD logic. Otherwise the CPU reads the end of the ST_DTACK cycle and completes ROM access a lot sooner, normally before ROM is even ready.


A edit to the ROM code and we jump to 345%. I think thats as good as its ever going to get.

dt2.jpg
dt2.jpg (72.72 KiB) Viewed 3369 times
I removed my DTACK resistors and got 164% first test, and it crashed on the second test :roll: Either way DTACK will likely need a lower value to gain the extra speed.

Next to try about 600R on ST_DTACK.. First GB6 test 163% and ROM speed is 309% again. So seems 400R is needed , thats a little low really.


more to come later...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC »

My board arrived today, hope to test it out tomorrow. :cheer: :cheer:
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by Icky »

PhilC wrote: Thu Jan 16, 2020 8:38 pm My board arrived today, hope to test it out tomorrow. :cheer: :cheer:
Great @PhilC. I just posted a guide on how to install here - https://www.exxosforum.co.uk/forum/viewt ... =78&t=2466

You can replace the ROM on the H4 with the 104/206 one you have on your IDE DEV board to take advantage of TOS 206.

Will be interesting to see how yours behaves compared to mine on the H4.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC »

@Icky yes thanks for posting that. I'll have a go a bit later on. Hopefully fix the SMT board too whilst I'm at it.
If it ain't broke, test it to Destruction.
Post Reply

Return to “SEC 64MHZ BOOSTER”