exxos IDE interface (untested)

Related information and WIP etc
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

PhilC wrote: Fri Apr 12, 2019 3:39 pm Are you leaving in the existing LED function as well?
This does not change the original LED function as such ...

But as the floppy light stays on even while the hard drive is accessed (yellow) , the firmware should actually turn off the yellow LED and light up the green one only... So this will bypass what the ST is doing but only when the hard drive is accessed where the green LED takes priority and lights up without the yellow LED on.

The bottom line is, the floppy drive will always flash yellow as normal, and the hard drive will always flash green when accessed.



PhilC wrote: Fri Apr 12, 2019 3:39 pm Obviously this mod will look great on an STFM etc but would it be as practical on Mega's etc?
No idea, I don't really consider any other machines other than the STFM :)
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos IDE interface (untested)

Post by Icky »

Nice exxos. So what MOSFET did you go with in the end?
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

Icky wrote: Fri Apr 12, 2019 6:10 pm Nice exxos. So what MOSFET did you go with in the end?
NDD02N60Z But I don't plan to actually use that one... I want to use the BSS127 but I only found that after I did the order.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

As people are interested how fast the CPU can grab data from the IDE and dump it into RAM, which has nothing to do with how fast the interface or IDE device is...

ide.jpg
ide.jpg (37.81 KiB) Viewed 5954 times

This speed is as fast as it can be as it uses a single 68000 bus cycle. Faster speeds needs 16MHz CPU and faster RAM. In theory 16MHZ CPU & RAM would be 2840 kb/sec, where I assume would be Falcon speeds (though CPU caches may give higher apparent speeds, I haven't tested it out.)

Incidentally the interface can easily run at 100MHz.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
displaced
Posts: 42
Joined: Sat May 19, 2018 11:15 pm
Location: UK

Re: exxos IDE interface (untested)

Post by displaced »

Well I started this evening with looking at if I should buy an Ultrasatan and see if I could fit it internally in an STFM... and ended up reading this entire thread instead!

This looks fantastic -- well done to you both -- very tidy, and really reliable it seems! Looking forward to ordering the production version when it's available.

Fingers crossed it'll fit on a C103253 motherboard (even with the daft Marpet SIMM adapter hogging the MMU).

In the meantime, I'm eyeballing my internal Gotek and wondering if there's room on the front of it to hack a slot for an SD card...

Cheers,
Chris
A bunch of Ataris and others:
Atari XEGS with RGB mod - STFM - Portfolio - Lynx Mk1 with McWill display - Mega STE - Falcon030 - Jaguar
Commodore VIC-20 CR with ClearVideo - CDTV (Wicher 8MB+IDE)
Acorn Electron - Archimedes A3020
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

Thanks :)

We always trying to make things fit and be as small as possible.. Mostly we work with the CO70789 boards as they are generally the best ones to work with.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
displaced
Posts: 42
Joined: Sat May 19, 2018 11:15 pm
Location: UK

Re: exxos IDE interface (untested)

Post by displaced »

Looking at the C070789 vs. My board, it looks like mine has more overlap between the MMU and CPU. Might be an issue, might not!

I seem to remember there still being a decent amount of space between the top of the Marpet MMU adapter and the shielding, so should be able to stack the IDE board up to go above. Might even have to replace the IDE pins with a right-angle set (or go maximum-bodge and solder the ribbon wires direct to the board).

Will cross that bridge when I get to it... where there’s a will, there’s a way!

Have read all the way through the beta feedback thread too - sounds like things are going well!
A bunch of Ataris and others:
Atari XEGS with RGB mod - STFM - Portfolio - Lynx Mk1 with McWill display - Mega STE - Falcon030 - Jaguar
Commodore VIC-20 CR with ClearVideo - CDTV (Wicher 8MB+IDE)
Acorn Electron - Archimedes A3020
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

Going back to the LED test https://www.exxosforum.co.uk/forum/viewt ... 100#p20450

I just did the proper schematic and PCB..

Problem is JLC can't do less than 2cm boards. So I may try and tile these and just hacksaw them out when I get the panel or something...

1.JPG
1.JPG (20.06 KiB) Viewed 4343 times
Capture.JPG
Capture.JPG (36.52 KiB) Viewed 4343 times

For those who have no idea what this is.. It is relating to the jumper link on the H4 near the keyboard connector ;) but this was intended for a modification to the IDE boards was never done in firmware because I never had the hardware to try with.. In any case this update will be compatible with future IDE boards.

Basically the Yellow floppy LED signal is driven by the IDE logic.. So floppy access lights up yellow as normal, but upon IDE access, the LED will light up blue (or green or whatever) .. This had to go via a PLD because otherwise the floppy would always override the IDE light if copying between hard drive and floppy etc.. So basically the hard drive light will always be essentially a override light to the floppy drive.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6049
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos IDE interface (untested)

Post by PhilC »

Put a row of holes between the tiles and just snap them apart?
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos »

PhilC wrote: Wed Oct 07, 2020 9:58 pm Put a row of holes between the tiles and just snap them apart?
Like this :P

11.JPG
11.JPG (75.09 KiB) Viewed 3804 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Locked

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”