Confirming no compatibility with A570 CD-ROM

TF534 - 68030 + More RAM Board (More compatible with amiga hardware)

Moderators: terriblefire, Terriblefire Moderator

dalek
Posts: 225
Joined: Thu Nov 08, 2018 11:03 am
Location: NSW Australia

Re: Confirming no compatibility with A570 CD-ROM

Post by dalek »

Thanks for the pointers guys :)

I'm going to keep looking at it as I'm enjoying modifying /learning about the firmware / verilog and the 68000/030 bus cycles - even if I don't get anything going.

There are clues in Matze's code that I'm looking at too. I'll be happy enough even if I can get some timings hardcoded at 50MHz just for my case.
terriblefire
Moderator Team
Moderator Team
Posts: 5423
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK

Re: Confirming no compatibility with A570 CD-ROM

Post by terriblefire »

I see people talking about CFGIN and CFGOUT all over the amiga universe. All this does is set the order cards get configured in.. or more precisely to prevent cards being configured at the same time.

But there are other ways to do this and anything that doesnt have access to those pins will just hide cycles to the main bus until everything it has is configured.
———
"It is not necessarily a supply voltage at no load, but the amount of current it can provide when touched that
indicates how much hurting you shall receive."
dalek
Posts: 225
Joined: Thu Nov 08, 2018 11:03 am
Location: NSW Australia

Re: Confirming no compatibility with A570 CD-ROM

Post by dalek »

I did end up getting a logic analyzer and from what I can see between the A570 and the edge connector is that with the 030 the BR/BG oscillates a few times whereas with the plain 68000 it's steady and reliable. I haven't really worked out why.

I'm not fully understanding it yet (and have had it all packed away for a little while). This all happens well before autoconfig so I'm sure that's not the issue.

I'll get back around to it one day, hopefully a little bit wiser and make a little more progress :)
2020-05-24 15_21_54-LA2016 Connected - KingstVIS.png
2020-05-24 15_21_54-LA2016 Connected - KingstVIS.png (144.04 KiB) Viewed 2801 times
2020-05-24 10_34_37-LA2016 Connected - KingstVIS.png
2020-05-24 10_34_37-LA2016 Connected - KingstVIS.png (131.1 KiB) Viewed 2801 times
Sorry I don't have a zoomed in one showing the issue more clearly. I was testing with a TF530 as the firmware was available to play with (and it was clocked slower).
Post Reply

Return to “TF534 (OBSOLETE)”