True 16MHz Mode

Related information and WIP etc
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: True 16MHz Mode

Post by exxos »

PhilC wrote: Thu Jun 06, 2019 10:12 pm This is starting to sound very much like the faulty DMA I had in one of the Megas. Is it worth a try with changing it for another BAD-DMA?
I will see if I can find one...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: True 16MHz Mode

Post by exxos »

exxos wrote: Thu Jun 06, 2019 10:23 pm
PhilC wrote: Thu Jun 06, 2019 10:12 pm This is starting to sound very much like the faulty DMA I had in one of the Megas. Is it worth a try with changing it for another BAD-DMA?
I will see if I can find one...
Nope, not the DMA chip.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: True 16MHz Mode

Post by exxos »

Did a video... watch it all, and you will see what I mean...


https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: True 16MHz Mode

Post by PhilC »

If it's working fine in Ickys machine then the theory is fine, it's just duplicating it.

Again it reminds me of trying to use the Pak 030 in a machine that had 150ns ram, some times it booted perfectly but others it showed rom or ram faults. So since this is related to the floppy, is it worth swapping 68901, 1772 and the ym2149?

Its got a be a silly timing issue between chips.
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: True 16MHz Mode

Post by exxos »

I've swapped, CPU, GLUE, MMU, RAM, 1772, DMA, ROM so far.

I will have to put jumper links in all the clock lines so I can jumper in stock clocks and new clocks as I think Icky was planning.. I think there is some odd fault on my remake board... it had been working fine a few weeks ago, never had any issues at all.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: True 16MHz Mode

Post by PhilC »

Sounds like we just need a couple more test subjects to verify then.

Then it's out with the scope for you then exxos.

I put my STF away one month, for it never to work again, lol, so know the feeling.
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: True 16MHz Mode

Post by Icky »

PhilC wrote: Fri Jun 07, 2019 6:33 am Sounds like we just need a couple more test subjects to verify then.

Then it's out with the scope for you then exxos.

I put my STF away one month, for it never to work again, lol, so know the feeling.
Now you have got your PAK working may be its time to pull out the STF and get it back up and running :)

Would be good to see how the other STF's behave at 16MHz.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: True 16MHz Mode

Post by PhilC »

Yeah, call it laziness. It's missing a couple of video signals like Vsync thanks to a PCB manufacturing defect but hopefully I'll track the rest down.
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: True 16MHz Mode

Post by Icky »

Just trying to track who has the 16MHz mod installed and in what state it is

As far as we know reading various threads here are states of STF Remake 16MHz mods. Let me know if I have any info wrong or if you have added the 16MHz mod and we don't know about it.

  • Icky's - Running stable with blitter
  • Exxos' - Not so stable with blitter
  • PhilC - Not so stable and won't run blitter
  • kodak80 - Read on thread kodak80 was ordering some 16MHz mod pcbs not sure the status
  • PaulJ - Looking to build shortly
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: True 16MHz Mode

Post by exxos »

Mine works fine with glitter. It can run all day. Mine is currently broken as I was investing the boot issue. Its pending me making the sync board for it.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”