exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
JezC
Posts: 2156
Joined: Mon Aug 28, 2017 11:44 pm

Re: exxos blog - random goings on

Post by JezC »

:yay2: :thumbup: :cheers: :2k2:
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10863
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: exxos blog - random goings on

Post by rubber_jonnie »

She lives!!


:girldance: :girldance: :girldance:
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
stephen_usher
Posts: 5840
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: exxos blog - random goings on

Post by stephen_usher »

:dualthumbup:
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.
User avatar
PhilC
Moderator
Moderator
Posts: 6049
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC »

Long live the Frankenscreen
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Hmmmm M'Kay....

Capture.JPG
Capture.JPG (181.54 KiB) Viewed 2967 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

RAMdomizer soldered in:)

Next to find some DRAM to test it with :)

IMG_5050.JPG
IMG_5050.JPG (358.13 KiB) Viewed 2940 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

All that was a fail... Short-circuits across the power rails somewhere :roll:

So started sucking up the VCC pins as it is the only place which can be shorted to GND... and did not find anything wrong :roll:

Loaded up the PCB file, ran DRC.. no problems found..

Tried a blank new PCB and the short is on the PCB itself somewhere :roll: :headbang:

IMG_5051.JPG
IMG_5051.JPG (336.01 KiB) Viewed 2934 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
derkom
Moderator
Moderator
Posts: 1225
Joined: Sun Jul 29, 2018 6:45 pm

Re: exxos blog - random goings on

Post by derkom »

Is it just me, or do you have a track running right into those holes?

Edit: I guess it does steer around them. Looks mighty close. :)
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

derkom wrote: Mon Apr 27, 2020 4:03 pm Is it just me, or do you have a track running right into those holes?

Edit: I guess it does steer around them. Looks mighty close. :)
They do steer around the holes... The socket holes look like they might be Via's under the microscope, but I cannot get continuity across any of them...

The board alignment top and bottom looks pretty spot on.. :shrug:

Capture.JPG
Capture.JPG (71.16 KiB) Viewed 2925 times

I might just hook it up to my big power supply and crank up the amps until something catches fire :twisted: :twisted:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Right, here is a exxos lesson in fault finding a power rail short..


First up a proper low resistance meter..

IMG_5052.JPG
IMG_5052.JPG (375.13 KiB) Viewed 2915 times


Basically what we do is check the resistance across various capacitors around the board and look at the resistances...


I started at the bottom right corner of the board working my way up with and to the left taking note of the resistance...Which is 84.2mR..

IMG_5057.JPG
IMG_5057.JPG (326.58 KiB) Viewed 2915 times

Moving upwards on the board you can notice the resistance gets slower, so we are getting closer to the short! Now 35.9mR!


IMG_5056.JPG
IMG_5056.JPG (398.05 KiB) Viewed 2915 times

Now I can only move to the left...So moving along one by one the resistance got lower and lower until there was nowhere else to go...

IMG_5055.JPG
IMG_5055.JPG (419.83 KiB) Viewed 2915 times

This is the lowest resistance point on the whole board on the power rail at 11.3mR.

So checking what capacitor that is on the PCB files...

Capture.JPG
Capture.JPG (78.88 KiB) Viewed 2915 times

D'oh! :headbang:

It looks like when I moved the capacitors about, to the right, I must have missed that one for some reason it should have been further to the right :roll:

Bodge wire time...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”