exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Icky wrote: Fri Jul 26, 2019 11:14 am Got it to 99.9% now :) but as you say its still taking chunks out of the GND layer
I turned off GND & VCC layers, its on optimise 1 currently..

But looks like it did what V7 did and route the signals already routed :roll:

Capture.JPG
Capture.JPG (33.02 KiB) Viewed 3830 times

I think Eagle router just doesn't do what I want it to do :(
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

2.5 hours and it finished routing. So its twice as fast as the V7 router easily. Though it doesn't help when it crashes, so its unusable anyway. I half think I could have routed the whole thing manually by now :roll:

What I can either do is try and fix the one where it trashed the ground plane, or do some more routing manually and then try the autorouter again :roll:

One thing I have been wondering, is moving the bus pull up resistors to the 68K expansion socket area as opposed to the CPU area...

Basically because the two resistor packs to the right of the CPU squashing up a lot of tracks, so it may ease the routing if they were moved elsewhere...

11.jpg
11.jpg (159.1 KiB) Viewed 3814 times

I wanted to keep the pull-up resistors close to the CPU, though with this board aiming towards a CPU expansion board, the pull-up resistors would probably be better close towards the expansion sockets anyway...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6049
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC »

See what you mean, with them next to the CPU makes for a very congested area.

Besides we can always budge more pullups on if necessary.
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

PhilC wrote: Fri Jul 26, 2019 2:34 pm See what you mean, with them next to the CPU makes for a very congested area.

Besides we can always budge more pullups on if necessary.
Yeah, I'm sure there will be some resistors to bodge on somewhere :)
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Started moving the SILs...

While I am messing about, I started to get rid of some of the angles in the buses between the 68K sockets.. get rid of those nasty angles a bit..

333.jpg
333.jpg (191.26 KiB) Viewed 3800 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos blog - random goings on

Post by Icky »

exxos wrote: Fri Jul 26, 2019 3:48 pm Started moving the SILs...

While I am messing about, I started to get rid of some of the angles in the buses between the 68K sockets.. get rid of those nasty angles a bit..
Careful. You will end up routing the whole board by hand :)
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Icky wrote: Fri Jul 26, 2019 4:25 pm Careful. You will end up routing the whole board by hand :)
Yeah, it seems to be going that way anyway :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

resistor packs moved, and expansion sockets re-tracked..

1.jpg
1.jpg (226.82 KiB) Viewed 3786 times

I was half thinking of just leaving this resistor pack there, but I think in terms of consistency, I will move it near the other ones I have just moved as well.

2.JPG
2.JPG (182.32 KiB) Viewed 3786 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

and we off...

I can see at the top ( marked with white arrows) there was a lot of buyers simply because of one trace, if the optimisations don't solve it, I will do a little bit of routing of that part manually on the VCC layer and hopefully that part will get a little neater then...

Capture.JPG
Capture.JPG (249.04 KiB) Viewed 3776 times

EDIT:

Is it me, or does this look super nice in blue ?

blue.JPG
blue.JPG (328.12 KiB) Viewed 3773 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

So after a epic 12hours , it finally routed without trashing the gnd layer :D so moving those resistor packs has given it a bit more room for routing. So next I will see where the bottlenecks are on the routing to see if I can improve on it.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”