exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
stephen_usher
Posts: 5970
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: exxos blog - random goings on

Post by stephen_usher »

So, you're out of a duck?
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

stephen_usher wrote: Sun Dec 10, 2023 7:48 pm So, you're out of a duck?
The rubber duck was my last friend.

I think the ChatGPT is starting to get annoyed with me as well...
I see, thank you for the clarification. If the structure of your HTML varies and you want to capture additional information without losing the previously extracted data, you might need to modify the script accordingly.
In other words do it yourself if you're not happy then :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

This present arrived for me today from a forum member. So it seems I have at least one friend somewhere. Or maybe I made the whole thing up just to make it seem like unpopular! :lol:

Thank you very much, you know who you are :)

IMG_1726.JPG
IMG_1726.JPG (80.92 KiB) Viewed 10454 times

Hopefully will make getting those PLCC chips out of sockets without destroying the socket and the chip easier in future :D
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Great, what a wonderful xmas present to be shut down while all this crap is sorted out. I guess its good I took my store offline when I did as currently I won't get the sales money.

1.jpg
1.jpg (32.87 KiB) Viewed 8874 times
2.jpg
2.jpg (41.5 KiB) Viewed 8874 times

I mean what in the hell do they think I am selling.
https://stripe.com/gb/legal/restricted-businesses

Like how many years have I been with Stripe now...

Had all this with PayPal as I am sure everyone remembers. They shut me down and for the best part couldn't even tell me why. I had a feeling some a$$hole reported me back then to shut me down, but I could never get anywhere with Paypal. Though I am also pushing for answers this time with Stripe to see how all this came about.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: exxos blog - random goings on

Post by rubber_jonnie »

exxos wrote: Thu Dec 21, 2023 11:49 am Great, what a wonderful xmas present to be shut down while all this crap is sorted out. I guess its good I took my store offline when I did as currently I won't get the sales money.


1.jpg

2.jpg


I mean what in the hell do they think I am selling.
https://stripe.com/gb/legal/restricted-businesses

Like how many years have I been with Stripe now...

Had all this with PayPal as I am sure everyone remembers. They shut me down and for the best part couldn't even tell me why. I had a feeling some a$$hole reported me back then to shut me down, but I could never get anywhere with Paypal. Though I am also pushing for answers this time with Stripe to see how all this came about.
It really is nuts. I just read the detail at the link and the only possible thing I can see is the section: Products and services that infringe intellectual property rights

But since it's mostly stuff of your design and only intended for Atari, not sold as 'made by Atari', and stuff that isn't yours either being items you've got agreement to sell or just components, it really makes no sense.

Surely you have a right to ask them what the issue is?
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

rubber_jonnie wrote: Thu Dec 21, 2023 11:57 am It really is nuts. I just read the detail at the link and the only possible thing I can see is the section: Products and services that infringe intellectual property rights
Yeah, I mean I use the word "Atari" but only "Atari" could take action on the name.. I mean if I was hacking something like the 2600+ then they might have a case, but people hacked the flashback and nothing happened AFAIK. But in my experience, companies generally issue a cease and desist notice before anything else. So I don't think this is "Atari" related. It would be a pretty low thing for them to do.

I think it's a bit of a grey area in some respects because I have to list models of machines like "Atari ST", but this is a reference and not me claiming to be Atari themselves. But again I don't think even Atari would stoop this low... They don't have any investment in the ST range AFAIK anyway. It's all 2600 type stuff.
But since it's mostly stuff of your design and only intended for Atari, not sold as 'made by Atari', and stuff that isn't yours either being items you've got agreement to sell or just components, it really makes no sense.
Indeed any software and hardware in my store is all passed through my own hands in one respect or another. So if anyone owns the IP stuff in my store, it is me personally.
Surely you have a right to ask them what the issue is?
Yep. So far they just said..
Thanks for reaching out to Stripe. I'm currently reviewing your request with the team and rest assured we'll get back to you once we have an update to share. In the meantime, please let us know if you have further questions – we're here to help.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Another unsurprising emergency light failure. Same problem corroded battery terminal. But the battery was not charging at all. I had it on my power supply and even at 20V it was pushed to draw 14mA! The LED light started smoking at about 7V and went a odd colour :lol: so the battery must be around 5V ish.

I flipped the little cover of the top of the battery and saw two little bunghole which I removed. I wondered if it was a lead acid battery. So I shook it upside down on some bog roll and lots of presumably carbon fell out.

So I decided to dismantle it.. Just seems to be layers of assume, zinc, then what looks like cotton wool almost, then presumably a chunk of carbon. It looks like there's two layers of the cotton layers stuff. It also looks like there's another compartment below so four layers. Further assume that it is basically for cells and assuming 1.5V per cell ~ 6V so sounds about right.

So no idea was really happened other than presumably the cotton layer is the electrolyte which again presumably has dried out. No idea what rechargeable batteries are construction wise anymore.

No idea what the battery is unless anyone recognises its construction.. Though I really wonder if it is even a rechargeable battery at all..

IMG_1731.JPG
IMG_1731.JPG (263.75 KiB) Viewed 6547 times
IMG_1732.JPG
IMG_1732.JPG (261.21 KiB) Viewed 6547 times
IMG_1733.JPG
IMG_1733.JPG (213.99 KiB) Viewed 6547 times
IMG_1734.JPG
IMG_1734.JPG (243.63 KiB) Viewed 6547 times
IMG_1735.JPG
IMG_1735.JPG (205.48 KiB) Viewed 6547 times
IMG_1736.JPG
IMG_1736.JPG (292.93 KiB) Viewed 6547 times
IMG_1737.JPG
IMG_1737.JPG (240.96 KiB) Viewed 6547 times
IMG_1738.JPG
IMG_1738.JPG (348.82 KiB) Viewed 6547 times
IMG_1739.JPG
IMG_1739.JPG (424.7 KiB) Viewed 6547 times
IMG_1740.JPG
IMG_1740.JPG (327.13 KiB) Viewed 6547 times
EDIT:

Looking around it could be NiCd after looking at this video..

https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

How odd. Battery was left over the weekend and now looks very wet :shrug:

IMG_1741.JPG
IMG_1741.JPG (329.11 KiB) Viewed 5798 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

I've been quiet this past week, rant pending below. I certainly don't claim to be unique with life problems that I'm having to deal with in life, though I'm sure people have got the gist by now that every single week there is some dilemma which I end up dealing with which I should not have to be dealing with in the first place.

My hands are still hurting from all the work I did on the wiki and I can never seem to get a break from anything. I need to concentrate on paying my bills and not just doing endless hundreds of hours unpaid work all the time. I am still trying to plod along with store items in the background but it is becoming ever increasingly difficult to find time for it all. So I will likely won't be posting much being involved much with the forum or doing any Atari stuff for the foreseeable future.

Now for the rant part which everyone can skip if they want.

A few weeks back I was at my girlfriends and went to the bathroom and it was raining from the bathroom ceiling. Basically the idiot upstairs had leaking sink pipes. Even though he claimed he used to be a plumber, he also claimed he had no pipes behind his sink and was adamant it was not leaking. He said he put towels down just in case but the water still continued to pour down.

We called out the landlord who sent out an emergency plumber which turned into a bit of a battle with the guy in the flat above because he would not let anyone in his property. I think he has some sort of hoarding problem because he was chucking out loads of carrier bags of rubbish while I was basically getting extremely mad with him because emergency plumber had been stood outside with me for almost half an hour. The plumber was getting annoyed and said he was just going to turn off the water totally because he hasn't got time to wait around. In the end we managed to get the plumber in the immediately found that is pipes behind his sink, hot and cold, were leaking so he turned them off and basically left it like that. Now this weekend it was a similar situation but even worse.

Basically I went in the bathroom to find sewage pouring from the ceiling. The only saving grace was my girlfriend was paranoid and left a container in the bathroom expecting it to leak again from the time before. This caught the brunt of the sewerage but of course splashes and the total stink of it all..

So I went around to the guys flat upstairs banging on the door for about 15 minutes until he actually answered it. I said he has got a leak again, has he turned on his taps. He said no and I said well you have got a leak somewhere again. At first I thought it was the water leaking again but he was very adamant he had no water leaks. I went back into my girlfriend's flat and woke her up and told water is leaking from the ceiling again. She got up to look and said that is not water it is sewerage. Because of my sinus problems, particularly in the morning, I did not realise it at the time.

So I went back banging on the upstairs flat door saying his toilet must be leaking. He was very adamant it wasn't and basically every single time he tried shifts the problem to being in our property not his. He went and looked and said his toilet is not leaking but he would put towels down just in case. But it kept on leaking in my girlfriend's flat.

So I said I would have to call the emergency plumber out to figure out where the leak is. This caused further problems because he said he was going out. So basically I to get hold of the landlord who had to get hold of the plumber to say not to come until after 6pm because the guy would not be in . Thankfully he did return in due time. Though we was sceptical he would let the plumber in because he outright refused the last time the plumber went out because of his leaking pipes.

So around 6.30pm the emergency plumber came out. He took one look and said he's not touching it because he has a four-month-old baby. I said I don't really blame him. Thankfully the guy in the flat above let him in and he took pictures and basically said he could not see anything obvious..BUT... He showed me the pictures and his bathroom and it is completely destroyed. Imagine the filthiest bathroom imaginable in the world and it is probably his bathroom. After seeing the look of shock and terror onto plumber's faces now they even said it was the worst one they have ever seen.

The plumber basically left and said he needs to ring the landlord to get dynorod out to unblock his toilet. Though now is where things get really interesting. Because the plumber flushed his toilet twice and we had no leaks appearing in our bathroom ceiling. So it was rather puzzling what was going on.

So I heard the guy from my girlfriend's flat he seemed to be talking to someone on the phone so we assumed he was talking to the landlord about getting his toilet fixed. Though he did not have the number and took it from my girlfriend..The problem is, I'm sure his toilet has been broken for at least two years, his sink pipes have not been fixed from several weeks back, and he also claims his roof has been leaking for the past year. At this point we was sceptical who he was even talking to if anyone at all. He claims the reported leaking pipes twice, but he did not have the number so... Plus I doubt anyone is going to leave a leaking roof for over a year.. Possible I guess but improbable.

So the next morning I heard a lot of banging, which is not really uncommon from the guy upstairs anyway. LAter, for some reason the guy told another neighbour that he had had a new toilet fitted. So I thought great for the problems are solved. But thought it was a little odd he did not tell me directly. I woke my girlfriend up and told her the good news and she said she is not convinced.

So she rang the landlord up to see if anything was going to be done about sewerage leaking from her ceiling and if the upstairs flat had reported any issues. She was on the phone about half an hour and the landlord basically said there has been no reports on that flat or any outstanding repairs on record. So you can imagine at this point how pi$$ed off we both was. As now we have totally conflicting things going on.

She explained the situation (but did not mention alleged new toilet ) the guy refusing access to the plumber previously. We did not mention the state of his bathroom either. But we would assume the plumber would be sending images to the landlord in that respect. But the guy basically needs a complete new bathroom. Landlord also explained if he refused access then it would be dealt with until there was a resolution.

So fast forward a few hours and dynorod turns up to unblock his toilet. They was there about half an hour wandering about with stuff. So I don't know what was the trigger for them coming out. But also why would dyno rod come out AFTER he allegedly had a new toilet fitted. Things are just not adding up at all.

What I think actually happened is his toilet was originally blocked. He kept on flushing it until it literally overflowed onto his bathroom floor. Which then leaked into our bathroom in the flat below. The plumber also said there is literally "crap" all over his floor. And after seeing the pictures, we was both pretty horrified by the state of it all.

So the guy in the flat above is blatantly lying what is going on has he claimed he was having a shower and he does not have a shower curtain so the water splashes on the floor.. I mean seriously why would you let so much water on the floor in the first place to the point it leaks though the floor to the flat below. If that was the case, it would have been watered like it was before not sewerage. So I'm basically concluding the guy is an outright liar.

Considering when we ring the landlord stuff is generally taking care of pretty much the same day. And yet this guy has been waiting over a year for his stuff to be fixed. Now this guy we do know has had mental health issues and he was in assisted living before he got booted out into his own flat. There was someone checking up on him every week but since covid, he only seems to come once a month now. Obviously there is a huge failure in the system, of no great surprise, that him being left to his own devices is simply not working. He just does not want to deal with his problems. And basically all his crap, literally and figuratively is becoming my problems and my girlfriends.

I've probably forgotten a bunch of details here and there but currently we are just trying to get the stench out of her bathroom and cleanup literally crap everywhere. Needless to say things are becoming a lot more complicated because we don't know who is telling the truth any more and I honestly believe the guy in the flat above is just a compulsive liar because he does not want people into his property to see the state which it is in. It is one thing to be ashamed, but he seriously needs help and seriously needs a new bathroom. Surely mentioned his bath taps were leaking at some point as well.

So literally we just got to the end of this yesterday. Then the electrician turned up for electrical inspection which we knew nothing about. The guy was super nice and no problems as such. Though when he left, my girlfriends TV now refused to turn on. So now I have gone back home and her TV is in bits while I try and fix it for her. Needless to say we have not finished with last week's bunch of crap yet.

I think is needless to say, this is a type of stuff I'm having to deal with every single week. Basically problems which are not my problems, or problems I just should not be dealing with. It's bad enough technology constantly breaking down and soaking up a lot of my time as it is. There's always something which has to take priority over everything else including actually paying my bills. I'm just too exhausted to keep dealing with everything under the sun every day.

So the bottom line is, I think this type of nonsense has being ongoing for the past two years now. I have ranted about it a lot every now and again. Though I think it is just become clear that I'm just not going to have time to do any Atari stuff for the foreseeable future. I'm just so far behind with everything that I am never going to be able to catch up. Frankly I am exhausted and just want to take a break from everything. So if people don't see me around for days weeks or months at a time then that is why. I will still try and respond to PM's when possible, but like this week , I just have not had time to even check messages. Everything is just a ongoing nightmare is frankly just beyond a ridiculous joke now.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Been poorly all week :( So for an "easy job", I decided to test some simms out and turned it into a load of the usual Atari related drama :roll: Frankly I am to poorly to start playing Atari games right now. So I am dumping this out there to drive everyone else nuts as well.

Basically I have 4 simms (I removed the parity chip on them, This was proven to aggravate the issues on some simms in some other videos I did this past week) . Anyway, In any pair combination they will all test fine. BUT when all 4 are in the STE, it has 99% RAM fail. I have repeated that test like 50 times. However, I have also tried my own simms in many times, and the 4MB will pass every time. Things do seem to slightly improve when mixing sets with the original RAM and 2 frontier RAM sticks. But it still fails.

Even though the RAM is stamped 80ns, it should be fine. My blue simms are 70ns. A lot of the simms I have are 80ns and they all seem to be failing when all 4 are in the STE, but when 2 are used for 2MB, they pass. So what to blame ? The RAM ? The STE ?!

I have noticed that RAS1 on the STE seems very sensitive to my scope probe. There are some fine tipping points to all this for some reason. But even if RAS1 failed, then why didn't the STE just "ignore" the upper RAM all together ? But why does it then fail on the "entire" RAM area. How did it get from a bad bank of RAM to the whole RAM bad. I don't get it.

There has to be some RAM timing issue going on. I think I know what part of it is as well and i've done work related before (the shifter timing issues etc) . So I think I already know where this timing problem is coming from. But one problem at a time. I want to rule out some other stuff first.

First problem, could well be that the RAM is to slow as 80ns fails. But what I don't get is, if the RAM *is* to slow, then why does 2MB work, and 4MB does not ? Do the RAM timings change depending on the amount of RAM installed ? Possible it could take longer to do refresh cycles on more RAM ? I don't know exactly how all that works. Generally you would think slower RAM would be more stable. But in this case, I think it might be the opposite. Hence needing to test more stuff out.

So here is a video I threw together. My voice is only just starting to come back, so I tried not to cough in everyone's ear to much. But be warned. While I have done several videos before this one, I doubt they will make it to my channel. I don't think there's much use in explaining every other little thing I tried (unless it gets mentioned here by someone else) .


https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”