exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Badwolf wrote: Sat Nov 26, 2022 12:49 am Have you hacked your PSU up to 5V yet? Genuinely think this is a massive issue with EtherNEC.

BW
Yep. But it does work of sorts with that program you posted.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

This has been a bit of a side quest to the other 50 side quests which are currently ongoing as well.. In that I have been extremely slowly working on GB7 in the background.

Currently myself and @dml Have been re-familiarising ourselves with how this stuff works. @dml Wrote the CPU tests which are written in assembly along with various other support routines.

GB7 will have adapted routines to verify the results of things like RAM tests. Currently it writes and reads values back from ram to obtain the speeds. However I think it would be really useful if some of these tests were verified that the results remained consistent. Basically a built-in diagnostics loop as well. The routines themselves will run marginally slower and the benchmark files from GB6 will no longer be compatible. So in order to not create any confusion I'm starting a new series of version 7 of GemBench.

I have been doing some various tweaks and bug fixes this past week as well. There is also another CPU test which I'm currently adding in.

Current problem is the test results never seem to get on the screen :shrug: by default the RSC file has "XXXXXX" in there which is cleared to "------" when GB7 loads.. however it does not seem to do the new test results despite me adding one onto the loop which does the clearing. And indeed results are not copied there either :shrug: Hate these silly mysteries :roll:

Steem__00027.png
Steem__00027.png (67.45 KiB) Viewed 838 times

There are a couple of other little features I want to add in as well. But will not get into it all at this point.

And no, I do not know how long it will be before GB7 is published even as a ALPHA.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

AHHHH :lol: :lol:

Code: Select all

	for n=0 to 15
	call DT(" ----- ",T1+n) ' time
	call DT(" ----- ",R1+n) ' ratio
result&(n)=0
	next n
T1 to T16 are the info boxes.. Only there are actually variables in the .BH file. So T1 = 3, as in object 3 in the tree.

Only for some bonkers reason it doesn't like the new object number T16..

BUT, If I manually do it like this...

Code: Select all

	call DT(" ----- ",T16%)
It works!

Capture.PNG
Capture.PNG (5.94 KiB) Viewed 828 times

That sux really as instead of a draw loop, I am going to have to have to edit chunks of code and do it all line by line :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
mrbombermillzy
Posts: 1493
Joined: Sun Jun 03, 2018 7:37 pm

Re: exxos blog - random goings on

Post by mrbombermillzy »

This one just doesn't get any easier does it?
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

mrbombermillzy wrote: Wed Nov 30, 2022 11:26 pm This one just doesn't get any easier does it?
Nope. Though I don't think it's a good idea to use variables that way in the first place :lol:

It's like doing..

A1=666
A2=666
A3=666

FOR B = 0 to 2
PRINT A1+B
NEXT B

Oddly that worked.. until now :lol: :roll:

I thought it could just be passing the loop number rather than the variable (666) but the variables are all kinds of numbers in the tree.. So god knows.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Think I got a typo somewhere :lol: ah screw it. going to bed 8-)

Capture.PNG
Capture.PNG (47.57 KiB) Viewed 817 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

AHHH its the new GB7 file @dml its not returning the test time anymore it seems :shrug:


I put back GB.O and tests now work again.

Capture.PNG
Capture.PNG (73.69 KiB) Viewed 814 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
dml
Posts: 165
Joined: Wed Nov 15, 2017 10:11 pm

Re: exxos blog - random goings on

Post by dml »

The test source I sent back returns 3 values for sys_tstop, as you wanted support for multiple returns.

Code: Select all

*-----------------------------------------------------------------------------*
sys_tstop:
*-----------------------------------------------------------------------------*
	move.l		arguments(pc),a6
	;
	; calculate time difference (currenttime-starttime)
	;
	move.l		$4ba.w,d0
	sub.l		starttime(pc),d0
	;
	; return result
	;
	move.l		arg_0(a6),a0		; a0 = first argument = BASIC varptr
	move.l		d0,(a0)			; write result to BASIC var, through (varptr)
	;
	move.l		arg_1(a6),a1		; a1 = second argument = BASIC varptr
	move.l		#1234,(a1)		; write #1234 to BASIC var, through (varptr)
	;
	move.l		arg_2(a6),a2		; a2 = third argument = BASIC varptr
	move.l		#5678,(a2)		; write #5678 to BASIC var, through (varptr)
	rts
For this to work you need to pass all 3 VARPTRs to the call (after the command number) or you will get undefined results.

You can remove the last 2 unused returns from the ASM to make it work like the original version.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

dml wrote: Thu Dec 01, 2022 8:15 am The test source I sent back returns 3 values for sys_tstop, as you wanted support for multiple returns.
For this to work you need to pass all 3 VARPTRs to the call (after the command number) or you will get undefined results.
Ah yes sorry :blonde:

Some reason I thought they were optional and I did not have to read them unless they were specifically needed for that routine.

So back up and running again :)

Capture.PNG
Capture.PNG (74.22 KiB) Viewed 773 times

Currently doing some more code edits.. geese I have learned a lot since I wrote GB6.. :lol: :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

@Badwolf and @Icky Will now be pleased to know there is now a " break out of loop" function. Now for example if you hold down ESC on the main GB6 screen while it is flashing the test black, the screen will flash blue to register you want to stop the loop test. And then it will stop.

This was a bit of a pain to program in. Simply because there is the actual function call to each test, which can then be called by the "All test" loop.. which is also them wrapped with the " run forever" loop. So it had to register the keypress and pass that "flag" to all the routines so each one exited correctly :roll: Originally was just to save repeating the same chunks of code.Well it works now anyway :lol:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”