exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Slightly better image of the Falcon RAM board with parts in situ.

Falcon_RAM.PNG
Falcon_RAM.PNG (254.46 KiB) Viewed 766 times

Annoyingly totally forgot to bring back the Falcon RAM boards. :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Just got a shipment notification from JLC that the RAM boards have been shipped. That was amazingly fast!

Asked my girlfriend to ship me one of the original RAM boards from stock today. It may or may not come tomorrow. Though I plan to have a day off on Wednesday anway. So I will pick the boards up then anyway. Then I will see if I can replicate the failure. It will be interesting if the same bit fails on a different board.

As I will have ( Assumingly ) 2 boards then which have failed. I will remove those remaining working DRAM chips and transplant them onto the new PCB. Then repeat the tests and see the same failure happens again or not.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

In amongst all the sticky boards I managed to find a working one :D Interestingly even though they are the same chips, some of them are stamped Germany and others UK.

Bit11 failed before. So will leave this board on for a bit. Will heat it up and turn it off/on at random points to see if it fails.

IMG_0158.JPG
IMG_0158.JPG (451.17 KiB) Viewed 724 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

6 hours it was on yesterday. I was turning it off/on about every hour and its not failed yet. Why do things never fail when they're supposed to :lol: :roll: Will leave it on all day today for a longer run.

Currently waiting to see if one of the other RAM boards turns up today. That one had the UK stamped chips. Currently starting to wonder if the Germany stamp chips are more resilient in the Falcons than the UK ones :shrug:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

No post today :cry:

RAM board still not failed. :roll:

Been busy making up boxes and packing up the next batch of power supplies today. Managed to box up 40 I think. I think there is about 50 left at my mate's house which he is still finishing off the assembly and testing. Then that is that for these power supplies. I do not plan to make any more of them up because they just take up a enormous amount of time and effort :( I do have some remaining transformers where I do want to build an updated design using a different brand of switch mode chip. But I don't think that will be any time soon.


IMG_0159.jpg
IMG_0159.jpg (29.86 KiB) Viewed 657 times
IMG_0160.jpg
IMG_0160.jpg (90.75 KiB) Viewed 657 times
IMG_0162.jpg
IMG_0162.jpg (54.51 KiB) Viewed 657 times
IMG_0163.jpg
IMG_0163.jpg (50.42 KiB) Viewed 657 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
mrbombermillzy
Posts: 1493
Joined: Sun Jun 03, 2018 7:37 pm

Re: exxos blog - random goings on

Post by mrbombermillzy »

Honestly, you are like a one man factory. (Well, maybe Dawn too.)

No wonder you have RSI! :o
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

mrbombermillzy wrote: Tue Nov 08, 2022 5:52 pm Honestly, you are like a one man factory. (Well, maybe Dawn too.)

No wonder you have RSI! :o
Yeah, I couldn't run my store if dawn didn't pack orders and posts them for me. It's the multitasking around 20 different projects which drains me mentally these days as well. There is just so much I want to do, but I'd be lucky to complete 10% of it all.

But like I've said before. I wanted to have a rest pre-covid time. I built up enough stock to theoretically last 1-2 years. Then covid hit and that stock was wiped out in under 3 months . Good in some ways, but not in others. So the past 2 years I've been doing 10x more work to try and do what I wanted to pre-covid time.

I think there is light at the end of the tunnel now though. Main problem is parts shortages. So some store items like the ROM related stuff may just go out of stock until the market recovers. But that could be slow going.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Thought I would open these boxes from JLC to see whats been sat on my floor for the past forever :lol:

I know both versions of the TOS206 boards are in there already. Along with the next (hopefully final V4 Falcon clock patch boards).

IMG_0164.JPG
IMG_0164.JPG (326.73 KiB) Viewed 620 times

I got a few pullup boards made for the H5 boards which ended up with the 4.7K resistors. IIRC those boards were unstable or didn't boot up at all. So this should be a easy fix than changing the tiny resistor packs.

IMG_0167.JPG
IMG_0167.JPG (254.48 KiB) Viewed 620 times

FPU OverClock PCBs. So you can drive the FPU direct from its own clock.

IMG_0166.JPG
IMG_0166.JPG (293 KiB) Viewed 620 times

Also the new batch of the STE DAC fix boards.

IMG_0165.JPG
IMG_0165.JPG (289.34 KiB) Viewed 620 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

More PCBWAY drama :roll:
as for the problem of RN1 RN9 RN10 RN12, we are checking the reason, I see that your BOM wrote LCSC model number C12001,which is 4D03WGJ0222T5E, but the quotation BOM we send to you is with model number FRC1206F2001TS, this maybe the reason buying wrong parts. Do you need us to buy the parts 4D03WGJ0222T5E for you to solder on RN1 RN9 RN10 RN12?
So they changed my BOM, god knows why, ordered wrong parts, then want me to solder the correct parts ?! Like no, I paid for THEM to solder the parts.

I honestly give up with them. I am just repeating myself all the time about the header pins. They keep wanting to solder them on the wrong side of the PCB. Its good they checking of course, but they are creating half the problems. I mean I uploaded images of the fully assembled thing when I uploaded the gerbers FFS! Whats the point of giving them assembly instructions if they never read them and repeatably ask the same questions over and over.

I'm not singling out PCBWAY as a bad company, every China company I deal with tends to result in chaos. But this has been 50x more effort than things normally are. The quality of the PCB and assembled so far has been the best I have seen. But while I have screwed up a lot of stuff, a lot could have been avoided if they were better organised. Most of the chaos could have been avoided if they just looked at the images I sent multiple times already.

So next PCB order I do, I will try a different company. My sanity can't cope with PCBWAY again after all this :(
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Does anyone know how to get the falcon IDE to work properly with windows ? :pullhair:

When I setup HD11 with TOS and WINDOWS I can see the partition on my PC and see newdesk.inf on it.. So I write files on the PC to the card.. Back on the falcon its no longer TOS compatible and if I enable it,it wipes the drive :roll:

Its frustrating as the only way to do it is to copy files to a floppy and then copy them on the falcon and never put the CF card in the PC.

I never had this problem with TRUDIE on the ST :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”