exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

:pullhair:

Code: Select all

Setting bed temperature to 60.000000 degrees Celsius.
Error:Heating failed, system stopped! Heater_ID: bed
[ERROR] Error:Heating failed, system stopped! Heater_ID: bed

echo:Heating Failed
Error:Printer halted. kill() called!
[ERROR] Error:Printer halted. kill() called!

Disconnected.

Wondering if its because I started at 28c :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Setting the bed at 60c.. The heater comes on for a bit and hits 47c, so way off.

On the status..

1.JPG
1.JPG (9.62 KiB) Viewed 2658 times
2.JPG
2.JPG (11 KiB) Viewed 2658 times

10/60 10 is what's in the file, and 60 is the set temp and 3685, then 3642 shows the sensor lowing in value.. sooo..

Code: Select all

{ OV( 3570 ), 54 },
 { OV( 3600 ), 52 },
 { OV( 3657 ), 51 },
 { OV( 3687 ), 48 },
 { OV( 3724 ), 46 },
 { OV( 3752 ), 43 },
 { OV( 3816 ), 38 },
 { OV(  3863), 31 },
 { OV(  3876), 29 },
3642, well 3657 51c.. close enough.. but nope, 47c not 51c... :WTF: and pronterface still showing 10c anyway.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

A possible thing is its actually set to 10bit resolution :roll:

Code: Select all

 #define THERMISTOR_TABLE_ADC_RESOLUTION 10
#define THERMISTOR_TABLE_SCALE (HAL_ADC_RANGE / _BV(THERMISTOR_TABLE_ADC_RESOLUTION))
#if ENABLED(HAL_ADC_FILTERED)
  #define OVERSAMPLENR 1
#elif HAL_ADC_RESOLUTION > 10
  #define OVERSAMPLENR (20 - HAL_ADC_RESOLUTION)
#else
  #define OVERSAMPLENR 16
#endif
#define MAX_RAW_THERMISTOR_VALUE (HAL_ADC_RANGE * (OVERSAMPLENR) - 1) 
So 10bits for 3000+ values falls a bit short... Well 2 bits :lol: :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Yep that was it. 12bits and now things are working as expected :dualthumbup:

43.16 / 43.00 and 43 on the bed :D

Capture.JPG
Capture.JPG (10.7 KiB) Viewed 2625 times

Now to see if any tables will work with my extruder..
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Having noticed the stock is running low on STE DUALTOS boards. I was considering getting the batch made up of these boards again..

DUAL_STE_TOS.jpg
DUAL_STE_TOS.jpg (23.71 KiB) Viewed 2605 times


But later on forgot that some years ago I did this board..

1.jpg
1.jpg (128.92 KiB) Viewed 2605 times

I think they were basically discontinued because the UBE circuit never was reliable and I did not have the time to solder the SMT sockets.

Though I am thinking of just removing the now-defunct UBE part and is producing those smaller more compact boards with the SMT socket. I'm hoping they will be much less outlay for me to get them into production.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Revamp done.

Capture.JPG
Capture.JPG (57.1 KiB) Viewed 2590 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

I'm still constantly chugging away in the background working on store items. For example today I am testing CPU's and DRAM. yesterday I was mostly working on ROM's.

A lot of items in my store are going out of stock. Basically because I am yet to invent the 5,000 hour day yet. But a lot of projects are being transferred over to the company which built the H5 motherboards for PCB and assembly. There will be a bit of a crunch when all this stuff turns up at once. So maybe sporadically quiet but working hard in the background to keep the items flowing in my store for people.

IMG_7181.JPG
IMG_7181.JPG (150.46 KiB) Viewed 2558 times
IMG_7182.JPG
IMG_7182.JPG (149.59 KiB) Viewed 2558 times

EDIT:

Looks like some projects starting to come into fruition

Capture.JPG
Capture.JPG (66.25 KiB) Viewed 2555 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24200
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

STFM DUALTOS 2022 remix.

Capture.JPG
Capture.JPG (70.92 KiB) Viewed 2506 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Badwolf
Posts: 2318
Joined: Tue Nov 19, 2019 12:09 pm

Re: exxos blog - random goings on

Post by Badwolf »

I saw from your stock thread that you've started doing the naked STE dual ROM boards. At £6, that's an absolute steal and I shall be investing for my next order. Many thanks.

BW
DFB1 Open source 50MHz 030 and TT-RAM accelerator for the Falcon
Smalliermouse ST-optimised USB mouse adapter based on SmallyMouse2
FrontBench The Frontier: Elite 2 intro as a benchmark
Post Reply

Return to “MEMBER BLOGS”