exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC »

@exxos I remember downloading the latest marlin build and then applying all the options to it myself manually, then it worked fine but it is most definitely a pain in the arse and not something I'm going to do with my printer again as its now working as I want it to.
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

PhilC wrote: Fri Nov 05, 2021 1:39 pm @exxos I remember downloading the latest marlin build and then applying all the options to it myself manually, then it worked fine but it is most definitely a pain in the arse and not something I'm going to do with my printer again as its now working as I want it to.
That's the thing though isn't it, if you download the Marlin firmware, as you can configure it for just about anything, then you would expect to need to configure it. But when BTT release fires you would at least think they would be set up for the board supposed to be for. I mean the firmware.bin (480K one) works fine so assume that is the default one sent with the board. But when I compile those files, it comes out at 159K.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC »

@exxos That is bizarre and must mean something big is missing, probably lots of code commented out still that needs enabling? I know that I had to select the correct steppers, bed size, bltouch, touch screen and a few other things like distances from head to BLtouch etc.
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

I have figured it out. The problem was not sleeping for three days :cry:

I had unplugged the X-stepper while troubleshooting the odd driver issues and forgotten to plug it back in again. Annoyingly it was the X-motor I was clicking in Pronterface after compiling and uploading the firmware :headbang: :headbang: :headbang: :headbang:

Commence chair smacking then I guess...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6069
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC »

As requested

:chairsmack: :chairsmack: :chairsmack: :chairsmack: :chairsmack: :chairsmack: :chairsmack: :chairsmack: :chairsmack:
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Endstops now working. BUT WTF minimum temps for the heater bed after I turn it on ?!

Code: Select all

Reporting endstop status
x_max: TRIGGERED
y_max: TRIGGERED
z_min: TRIGGERED
Setting bed temperature to 80.000000 degrees Celsius.
Error:MINTEMP triggered, system stopped! Heater_ID: bed
[ERROR] Error:MINTEMP triggered, system stopped! Heater_ID: bed

echo:Err: MINTEMP
Error:Printer halted. kill() called!
[ERROR] Error:Printer halted. kill() called!

EDIT:

Oh guess I should connect the sensor :lol: :roll: Question is where does it actually go ??


EDIT2:

Bow down to my red LED on greatness !

IMG_7178.JPG
IMG_7178.JPG (45.11 KiB) Viewed 2133 times

So something is a bit out as the 80c temp set comes out at 96c on the thermal probe :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Started doing my own thermocouple table which is taking ages. But how accurate do they need to be ? Most just seem to go up in 5c increments . One guy mentioned marlin would "fill in the gaps" but I cannot find if that is even true or not ?
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

:pullhair: :shrug:

In file included from Marlin\src\core\../module/thermistor/thermistors.h:199,
from Marlin\src\core\../module/temperature.h:28,
from Marlin\src\core\utility.cpp:26:
Marlin/thermistortable_909.h:51:2: error: narrowing conversion of '1.2969999999999999e+2' from 'double' to 'short int' [-Wnarrowing]
51 | };
| ^
Marlin/thermistortable_909.h:51:2: error: narrowing conversion of '1.187e+2' from 'double' to 'short int' [-Wnarrowing]
Marlin/thermistortable_909.h:51:2: error: narrowing conversion of '1.133e+2' from 'double' to 'short int' [-Wnarrowing]
Marlin/thermistortable_909.h:51:2: error: narrowing conversion of '1.058e+2' from 'double' to 'short int' [-Wnarrowing]
Marlin/thermistortable_909.h:51:2: error: narrowing conversion of '9.0799999999999997e+1' from 'double' to 'short int' [-Wnarrowing]
compilation terminated due to -fmax-errors=5.
*** [.pio\build\BIGTREE_OCTOPUS_V1\src\src\core\utility.cpp.o] Error 1

Code: Select all

const short temptable_909[][2] PROGMEM = {
 { OV( 2511 ),129.7  },	//95
 { OV( 2600 ), 118.7 },	//92
 { OV( 2658 ), 113.3 },	//90
 { OV( 2748 ), 105.8 },	//87
 { OV( 2806 ), 101 },	//85
 { OV( 2890 ), 95 },	//82
 { OV( 2948 ), 90.8 },	//80
 { OV( 3024 ), 86.9 },	//77
 { OV( 3080 ), 83.5 },	//75
 { OV( 3152 ), 80.4 },	//72
 { OV( 3200 ), 77.2 },	//70
 { OV( 3270 ), 75.7 },	//67
 { OV( 3295 ), 71.5 },  //65
 { OV( 3380 ), 67.1 },	//62
 { OV( 3425 ), 62.2 },	//60
 { OV( 3480 ), 60.2 },	//57
 { OV( 3522 ), 56.1 },	//55
 { OV( 3570 ), 53.9 },	//52
 { OV( 3600 ), 51.6 },	//50
 { OV( 3657 ), 50.7 },	//47
 { OV( 3687 ), 48.4 },	//45
 { OV( 3724 ), 45.7 },	//42
 { OV( 3752 ), 42.8 },	//40
 { OV( 3816 ), 38 },	//35
 { OV(  3863), 30.8 },	//30
 { OV(  3876), 28.8 }	//11
 };
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Badwolf
Posts: 2325
Joined: Tue Nov 19, 2019 12:09 pm

Re: exxos blog - random goings on

Post by Badwolf »

exxos wrote: Sun Nov 07, 2021 9:42 pm const short temptable_909[][2] PROGMEM = {
Round to the nearest integer?

BW
DFB1 Open source 50MHz 030 and TT-RAM accelerator for the Falcon
Smalliermouse ST-optimised USB mouse adapter based on SmallyMouse2
FrontBench The Frontier: Elite 2 intro as a benchmark
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos »

Badwolf wrote: Sun Nov 07, 2021 9:46 pm Round to the nearest integer?
I did wonder that :roll:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “MEMBER BLOGS”