kludge’s TF534 build

TF534 - 68030 + More RAM Board (More compatible with amiga hardware)

Moderators: terriblefire, Terriblefire Moderator

User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

8 Bit Dreams wrote: Tue Mar 26, 2019 5:12 am Yes, no Zorrolll RAM under KS 1.3 - that's normal.
Wich A500 Revision do You have rev.3 & rev.5 need to be modded to be able accept 512kb kickstarts
Rev 6A, so that shouldn’t be a problem. It’s modded for 1 MB chipmem though, with 512k onboard and 512 in the trapdooor.

I’ll put the 534 in my 500+ later to check if I get the same issue.
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 785
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: kludge’s TF534 build

Post by 8 Bit Dreams »

no, im talking about Kickstart roms, early motherboard revisions can't work with 512kb rom chips without modification. Since You have 6A - it should work with ks 3.1 & 3.1.4 just fine
Retro computer hardware & repair in Germany
User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

8 Bit Dreams wrote: Tue Mar 26, 2019 6:30 am no, im talking about Kickstart roms, early motherboard revisions can't work with 512kb rom chips without modification. Since You have 6A - it should work with ks 3.1 & 3.1.4 just fine
I know you were talking about the roms, but I just mentioned the chipram mods just in case that would be a problem (didn’t think it would be, but still).

Any Diagrom tests I missed?
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

Could it be a bridge on the RAM CPLD? It’s responsible for the IDE as well, right? And the IDE is untested still as I haven’t got my headers yet. Will get them today or tomorrow.

As KS1.3 doesn’t support it and 31/3.1.4 does, something sketchy on the IDE could probably cause some problems.
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: kludge’s TF534 build

Post by PaulJ »

kludge wrote: Fri Mar 22, 2019 9:44 pm
Morning Kludge, or good afternoon for you I guess.. :D Did you ever get your 530 running? I've run into a disconnect getting 534's so I was thinking of building the 530's. I just wanted to check if you were able to get your 530 running or did you abandon the effort? Thanks Paul...
User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 785
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: kludge’s TF534 build

Post by 8 Bit Dreams »

Emm..i think Pin1 mark of the ide is on the wrong side, try to twist the ide ribbon
Retro computer hardware & repair in Germany
User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

8 Bit Dreams wrote: Tue Mar 26, 2019 2:22 pm Emm..i think Pin1 mark of the ide is on the wrong side, try to twist the ide ribbon
I don’t have the headers yet, so the IDE is totally untested. Will get a couple (100) of headers this week.
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

PaulJ wrote: Tue Mar 26, 2019 2:15 pm Morning Kludge, or good afternoon for you I guess.. :D Did you ever get your 530 running? I've run into a disconnect getting 534's so I was thinking of building the 530's. I just wanted to check if you were able to get your 530 running or did you abandon the effort? Thanks Paul...
Good afternoon, indeed!

The TF530 is not working yet, but not abandoned. I’m getting a new soldering station tomorrow, and I’ll pick up the project sometime after that.
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
User avatar
kludge
Posts: 393
Joined: Thu Nov 08, 2018 2:05 pm
Location: Sweden

Re: kludge’s TF534 build

Post by kludge »

8 Bit Dreams wrote: Tue Mar 26, 2019 5:12 am Yes, no Zorrolll RAM under KS 1.3 - that's normal.
BTW, what Kickstart versions support Zorro III out of the box? 3.0 and later?
A kludge is a workaround or quick-and-dirty solution that is clumsy, inelegant, inefficient, difficult to extend and hard to maintain.

My lack of focus:
[ 4 * Amiga 500 ][ Amiga 500+ ][ 2 * Amiga 600 ][ A1200 ][ Amiga 2000 w/ A2386 ][ Amiga 4000/030 w/ CyberVision 64 3D, FastLane SCSI Z3 ][ CD32 ][ VIC-20 ][ 4 * C64 Breadbin ][ 5 * C64C ][ 2 * C128 ][ C128D ][ C64 DTV ][ Mac Classic ][ Mac Classic II ][ Mac Colour Classic ]
Justme14
Posts: 39
Joined: Tue Dec 18, 2018 9:28 pm
Location: Netherlands

Re: kludge’s TF534 build

Post by Justme14 »

Hi Kludge ,

What frequency is your cpu running ?
I had similar issues as while building the tf534, I used a 20Mhz crystal ,where Diagrom passed with all test ...
But KS 3.1 I had failed to start. I had this solved when I put a higher frequency as a 48Mhz crystal in ,and all was fine.

And yes the silk screen is wrong for the IDE for pin 1,this took me some time to figure this out as well :oops: ...
Post Reply

Return to “TF534 (OBSOLETE)”