TF330 Performance Improvements

68030 + SDRAM + IDE

Moderators: terriblefire, Terriblefire Moderator

Gooeyblob
Posts: 42
Joined: Thu Feb 28, 2019 8:23 pm

Re: TF330 Performance Improvements

Post by Gooeyblob »

I have an idea on how to speed up the Akiko routine and also cure the screen corruption issues...
pipper
Posts: 42
Joined: Tue Apr 23, 2019 5:55 am

Re: TF330 Performance Improvements

Post by pipper »

...turn off the data cache only during the Akiko C2P conversion?
Gooeyblob
Posts: 42
Joined: Thu Feb 28, 2019 8:23 pm

Re: TF330 Performance Improvements

Post by Gooeyblob »

No, data cache stays on!
terriblefire
Moderator Team
Moderator Team
Posts: 5431
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK

Re: TF330 Performance Improvements

Post by terriblefire »

Is this a tweek to the c2p routine?
———
"It is not necessarily a supply voltage at no load, but the amount of current it can provide when touched that
indicates how much hurting you shall receive."
Gooeyblob
Posts: 42
Joined: Thu Feb 28, 2019 8:23 pm

Re: TF330 Performance Improvements

Post by Gooeyblob »

Yes and it may be possible to use your boot rom to patch the graphics library so detection works.
User avatar
supaduper
Posts: 579
Joined: Thu Nov 08, 2018 12:05 pm

Re: TF330 Performance Improvements

Post by supaduper »

Just thought I would answer GadgetUK here as to his enquiry about MMU working on the TF330, so I swapped out the EC 68030 ( No MMU) for a full 68030 CPU ( with MMU, gold top)

I then installed the excellent Thomas Richter MMU libs which can be found easily on Aminet over my Classic workbench CF, then ran sysinfo just to get the results, I know sysinfo is not the best benchmark tool but for this purpose it will do fine, the results are blow , speed increase on the Drive is very nice indeed and the system works great with installed MMU libs
Attachments
TF330 with MMU.jpg
TF330 with MMU.jpg (205.74 KiB) Viewed 6035 times
TF330 no MMU.jpg
TF330 no MMU.jpg (236.63 KiB) Viewed 6035 times
TF330 MMU Sysinfo.jpg
TF330 MMU Sysinfo.jpg (345.21 KiB) Viewed 6035 times
terriblefire
Moderator Team
Moderator Team
Posts: 5431
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK

Re: TF330 Performance Improvements

Post by terriblefire »

Nice work.
———
"It is not necessarily a supply voltage at no load, but the amount of current it can provide when touched that
indicates how much hurting you shall receive."
User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 785
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: TF330 Performance Improvements

Post by 8 Bit Dreams »

This is why ive shipped my TF cards with MC68030RP33 CPUs - to get muFASTROM working..
The next problem was CF adapters from china - these decelerated IDE on TF534i instead of increasing speed, SD to IDE works nice

Next problem is that i have now about 30x 33Mhz CPUs that are not running/or not even boot @50Mhz on TF cards, what annoys me - that these CPUs are running for hours on other cards without a single issue, maybe Stephen can explain better what causes that, i really have no explanation for that.
Retro computer hardware & repair in Germany
User avatar
supaduper
Posts: 579
Joined: Thu Nov 08, 2018 12:05 pm

Re: TF330 Performance Improvements

Post by supaduper »

8 Bit Dreams wrote: Sun Sep 01, 2019 11:40 am This is why ive shipped my TF cards with MC68030RP33 CPUs - to get muFASTROM working..
The next problem was CF adapters from china - these decelerated IDE on TF534i instead of increasing speed, SD to IDE works nice

Next problem is that i have now about 30x 33Mhz CPUs that are not running/or not even boot @50Mhz on TF cards, what annoys me - that these CPUs are running for hours on other cards without a single issue, maybe Stephen can explain better what causes that, i really have no explanation for that.
I am surprised you even get 33mhz CPU to run at 50hz, I have about 6 out of ten success rate with my 40mhz ones to run at 50htz, I will have to send you a few of my reject 40hz ones for you to try
User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 785
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: TF330 Performance Improvements

Post by 8 Bit Dreams »

Surprisingly CPUs with older masks are working @50Mhz without any problems, while newer mask CPUs are able to run @40Mhz only..

Following masks reject to work on TF's for me:
68030RP33B 04D66C, 09D66C, 62C74N

bought 10x MC68030RP33C with 01F91C mask, this is latest mask available, and these are NOT working @50Mhz on TF cards (TF330 nor TF534), however woking fine on Blizzard IV 1230 @50Mhz and also 68030 TK.. So Yeah, no idea why.. Maybe because of INT2 workaround (not sure if it present in TF330 firmware) hopefully Stephen can explain this.
2019-09-01 18.10.20.jpg
2019-09-01 18.10.20.jpg (327.1 KiB) Viewed 5967 times
Ceramic CPUs are clearly rebranded, however these can do @50Mhz on Blizzard IV 1230
Retro computer hardware & repair in Germany
Post Reply

Return to “TF330”