Flashy Clock - Yet another DEV board

All the good stuff hardware and software wise for the Phoenix H5 series motherboards.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos »

Icky wrote: Thu Mar 19, 2020 8:59 pm @exxos - I am sure I can fit another chip on that board somehow :) However I think we now have to task of unpicking our conversations as to how we were going to get this thing to work.
Well the hack jobs I did worked, so if its doesn't work, its your PCB :lol:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Flashy Clock - Yet another DEV board

Post by Icky »

exxos wrote: Thu Mar 19, 2020 10:31 pm
Icky wrote: Thu Mar 19, 2020 8:59 pm @exxos - I am sure I can fit another chip on that board somehow :) However I think we now have to task of unpicking our conversations as to how we were going to get this thing to work.
Well the hack jobs I did worked, so if its doesn't work, its your PCB :lol:
Got it to boot with from the firmware @exxos was using on the V3 - 1508 mod :)

Now to start with the RTC first to see if I can get that working.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos »

Mine arrived today :)

Flash, RTC, alt-ram all packed into a 68K footprint. Just have to port the firmware over from the previous board next :)


2.jpg
2.jpg (49.24 KiB) Viewed 4270 times
1.jpg
1.jpg (66.63 KiB) Viewed 4270 times

In case anyone missed the test board..
ROM selections are saved in the NVRAM and restored at power up as well :)


https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Flashy Clock - Yet another DEV board

Post by Icky »

:thumbup:

And here it is in situ in my DEV motherboard which is also sporting the MMU and GLUE towers :)

IMG_4952.jpeg
IMG_4952.jpeg (246.61 KiB) Viewed 4249 times
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: Flashy Clock - Yet another DEV board

Post by PhilC »

You do like your towers don't you @Icky

That board does look good though.
If it ain't broke, test it to Destruction.
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Flashy Clock - Yet another DEV board

Post by PaulJ »

Icky wrote: Sun Mar 29, 2020 11:46 am :thumbup:

And here it is in situ in my DEV motherboard which is also sporting the MMU and GLUE towers :)
That board must reside near the ocean. You can tell be the larger houses are on stilts.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Flashy Clock - Yet another DEV board

Post by Icky »

Have been working through the board all day and have finally got the RTC and Flash functions working. We have found a few oddities along the way for example the RTC chip was initially had got itself into an always busy state and had to prod it to make it think it was not so it could be initialised. We working on ironing out the software and once we have the RTC and Flash areas solid we will start on the ALT-RAM.

Any how the clock functions work and am able to program and boot to one of 5 banks, one being the motherboard ROM, and then the 4x Flash banks. I'll do a video later on the programming and booting to each bank.

In the meantime here is a really wobbly video of the board programming a bank. Lets see if you can spot when the flash is being programmed :)

User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos »

Got mine plugged in... Just waiting on Icky to stop messing with me crappy software and send it me next :lol: :roll:


IMG_4977.JPG
IMG_4977.JPG (84.52 KiB) Viewed 4164 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: Flashy Clock - Yet another DEV board

Post by PhilC »

Yeah hurry up @Icky keep poor @exxos busy during his lockdown. Hes already crazy and we don't want him getting worse / better. (Delete as appropriate)
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos »

PhilC wrote: Tue Mar 31, 2020 4:55 pm Yeah hurry up @Icky keep poor @exxos busy during his lockdown. Hes already crazy and we don't want him getting worse / better. (Delete as appropriate)
I could update the software myself, but well, its tea-time, and icky may have sent it by then anyways.. i'm willing to take the chance...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “PHOENIX ZONE”