ST-IDE-ROM Dev Board v1 - BETA Testers

Related information and WIP etc
User avatar
derkom
Moderator
Moderator
Posts: 1225
Joined: Sun Jul 29, 2018 6:45 pm

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by derkom »

PhilC wrote: Thu Apr 09, 2020 8:36 pm Glad you got it sorted.
Quite literally in this case. Fixing the byte order has TOS 2.06 working fine. :)

Thanks for the tips!
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

There is still a few of the IDE V1C kits in my store if people are still wanting them. If not I'll reuse the PLDs for other projects.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
DoG
Posts: 1160
Joined: Sat Apr 07, 2018 12:26 pm

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by DoG »

exxos wrote: Fri Apr 10, 2020 12:44 am There is still a few of the IDE V1C kits in my store if people are still wanting them. If not I'll reuse the PLDs for other projects.
Yup, I fed Harry late last night. So I got one.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

Still considering no3, but will probably wait now, see what goes down re the corona virus. I don't necessarily need a 3rd right now.

@exxos I'm assumingyou intended to shut down the store as planned yesterday afternoon, though I see it is still live?
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

rubber_jonnie wrote: Fri Apr 10, 2020 10:05 am @exxos I'm assumingyou intended to shut down the store as planned yesterday afternoon, though I see it is still live?
https://www.exxosforum.co.uk/forum/viewt ... 606#p36076
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 11029
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

exxos wrote: Fri Apr 10, 2020 10:43 am
rubber_jonnie wrote: Fri Apr 10, 2020 10:05 am @exxos I'm assumingyou intended to shut down the store as planned yesterday afternoon, though I see it is still live?
https://www.exxosforum.co.uk/forum/viewt ... 606#p36076
Duh, got my days mixed up because of the bank holidays 🤪
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by JezC »

exxos wrote: Fri Apr 10, 2020 12:44 am There is still a few of the IDE V1C kits in my store if people are still wanting them. If not I'll reuse the PLDs for other projects.
@exxos Still wanting at least one (or a later version of the same)...but finds won't currently allow me to get one as well as the bits for finishing my first H4 :cry:
Mind you, I do have a few ACSI drives which I could use in the meantime :) ...but then I need to bodge board for the H4 for that...so will still be stuck sans HDD for a while on the H4s) :(

So, I had to prioritise the H4 over the IDE for now. Maybe when Harry is next open for feeding I might have enough spare funds... :roll:
User avatar
kodak80
Posts: 379
Joined: Sat Oct 21, 2017 1:14 am
Location: Brisbane,QLD Australia
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by kodak80 »

With these IDE boards, in the H4, can we connect the activity LED on the IDE board into the jumper for the keyboard connector where the floppy activity is jumpered to the keyboard connector? Would this then show IDE access on the keyboard LED?
Atari Falcon 030 | Atari 1040 STE | Atari 1040 STFM | Atari 1040 STF | Kryoflux & Supercard Pro Flux boards
Creator of the Atari ST Review magazine archive: https://www.chillichai.com/atari-st-review
User avatar
exxos
Site Admin
Site Admin
Posts: 24239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

kodak80 wrote: Sat Jun 27, 2020 11:55 am With these IDE boards, in the H4, can we connect the activity LED on the IDE board into the jumper for the keyboard connector where the floppy activity is jumpered to the keyboard connector? Would this then show IDE access on the keyboard LED?
Yep. I've not had time for it though. I designed a bicolour driver for it so the keyboard led will flash orange on floppy access as normal, and maybe blue for ide. Its why that H4 jumper was put there so the ide board can drive the signal.

https://www.exxosforum.co.uk/forum/viewt ... 430#p20430
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
JezC
Posts: 2178
Joined: Mon Aug 28, 2017 11:44 pm

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by JezC »

Icky wrote: Thu Mar 05, 2020 11:10 pm Right angled socket works really well with the CF card adaptors. Picture minus my thumb. Just need to find a ROM, CPU and do the patches before sorting out the firmware.
Hi @Icky , do you know the part number (or even manufacturer) for that right-angle IDE socket?

I'm trying to order the bits for building up the first of my IDE boards to go in H4 #1 ready to decode TOS 2.06 (or EmuTOS) for a TF536...

My other short-term option would just be to build up enough of the IDE board to provide the ROM decode functionality & then use the IDE i/f on the TF536 for a while (or try it with an ACSI drive...once I finish my first DMA bodge board :lol: :roll:

If I follow this latter approach, do you know what do I still need to fit on the IDE board? PLD + socket & pins to connect into 68K socket on the H4 board obviously, flying lead to the ROM select jumper on the H4 board...but what else?

I'm quite happy to test it as the ROM decode just with the H4 initially fi that's a safer route to follow?
Post Reply

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”