ST-IDE-ROM Dev Board v1 - BETA Testers

Related information and WIP etc
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PaulJ »

exxos wrote: Thu Mar 05, 2020 1:39 pm @Icky Found a, literally, "small issue" on the IDE header..
I will need to build one up and test it all works correctly before putting kits in my store yet also. But if all goes well (does it ever?) I hope they will start appearing over the next few weeks.
Sounds very promising Exxos. :) And it looks like the 44 pin cable fits.. :) :) Great work. :thumbup: :thumbup: :thumbup:
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by Icky »

@exxos - you exposed my thumb to the world :)

I plan on removing the connector tonight and putting in a right-angled socket one that the CF card will plug directly into.
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

Icky wrote: Thu Mar 05, 2020 6:55 pm @exxos - you exposed my thumb to the world :)
But its such a nice thumb.. could be a professional thumb model...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10867
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

Now my H4 mostly works, can I get some new IDE boards?
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

rubber_jonnie wrote: Thu Mar 05, 2020 7:02 pm Now my H4 mostly works, can I get some new IDE boards?
Sure, you can have a mostly working IDE board.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10867
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

exxos wrote: Thu Mar 05, 2020 7:03 pm
rubber_jonnie wrote: Thu Mar 05, 2020 7:02 pm Now my H4 mostly works, can I get some new IDE boards?
Sure, you can have a mostly working IDE board.
Thanks. I think.....
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by Icky »

Right angled socket works really well with the CF card adaptors. Picture minus my thumb. Just need to find a ROM, CPU and do the patches before sorting out the firmware.

IMG_4856.jpeg
IMG_4856.jpeg (310.34 KiB) Viewed 3973 times
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10867
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

WOOT!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

It all fits fine look , when'ya plug the right stuff in ;)
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PaulJ »

@exxos , can I use the IDE board but insert it with no processor and use the on board H4 processor? I suspect not but thought I'd ask.
Post Reply

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”