ST-IDE-ROM Dev Board v1 - BETA Testers

Related information and WIP etc
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by Icky »

PaulJ wrote: Sat Apr 06, 2019 6:14 pm Ya know guys, this is some kind of syndrome, one catches it from having to-many un-fu*k boards in their life. I blame this all on Exxos and his obsession with un-fu*kit boards. You can't deal with it unless it looks like downtown NYC or an other large city..!! You really need to seek out some professional help! :mrgreen: :mrgreen: :mrgreen:
Out of interest do you have a picture of where the board would be situated in the Mega?
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

PaulJ wrote: Sat Apr 06, 2019 6:14 pm Ya know guys, this is some kind of syndrome, one catches it from having to-many un-fu*k boards in their life. I blame this all on Exxos and his obsession with un-fu*kit boards. You can't deal with it unless it looks like downtown NYC or an other large city..!! You really need to seek out some professional help! :mrgreen: :mrgreen: :mrgreen:
I do remember asking many times for people to check the schematic, so I wash my hands of all that :lol:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PaulJ »

Icky wrote: Sat Apr 06, 2019 7:33 pm Out of interest do you have a picture of where the board would be situated in the Mega?
You unplug the fast rom adaptor and accelerator and there's plenty of room under the board, nothing sticking up other than a soldered in chip here and there. :) :) :)
IMG_1149C.jpg
IMG_1149C.jpg (775.03 KiB) Viewed 3497 times
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by Icky »

PaulJ wrote: Sat Apr 06, 2019 10:34 pm
Icky wrote: Sat Apr 06, 2019 7:33 pm Out of interest do you have a picture of where the board would be situated in the Mega?
You unplug the fast rom adaptor and accelerator and there's plenty of room under the board, nothing sticking up other than a soldered in chip here and there. :) :) :)
Not much stacking then. May be one socket, none if you are lucky. :)
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PaulJ »

exxos wrote: Sat Apr 06, 2019 7:43 pm
PaulJ wrote: Sat Apr 06, 2019 6:14 pm Ya know guys, this is some kind of syndrome, one catches it from having to-many un-fu*k boards in their life. I blame this all on Exxos and his obsession with un-fu*kit boards. You can't deal with it unless it looks like downtown NYC or an other large city..!! You really need to seek out some professional help! :mrgreen: :mrgreen: :mrgreen:
I do remember asking many times for people to check the schematic, so I wash my hands of all that :lol:
All humor aside when you decide to pull the trigger on H2 we should divide the schematics and layout pics up among the builders and have an organized effort to find issues prior to the spin. :thumbup: :thumbup: :thumbup: .
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by exxos »

Maybe. Only the changes I've made probably only make sense to me at the moment :lol:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10984
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

Well, apart from the ceramic caps, which could well be here at lunchtime anyway, everything else arrived at my office over the weekend, so I have lots of parts to fit in the next few days :)

EDIT: The caps just arrived :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PaulJ »

RJ, better get soldering.. I still haven't received my board so you should be able to be the first unless Phil switches from the 534s. Just remember the end of the iron that get hot is not a hand warmer.. :P :P :P I still have night mares about the pic of the little burned piggy.. :)
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10984
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by rubber_jonnie »

PaulJ wrote: Mon Apr 08, 2019 3:45 pm RJ, better get soldering.. I still haven't received my board so you should be able to be the first unless Phil switches from the 534s. Just remember the end of the iron that get hot is not a hand warmer.. :P :P :P I still have night mares about the pic of the little burned piggy.. :)
Don't worry, no more burned pinkies for me!

With a bit of luck, and a following wind, I can get the assembly finished tonight, though testing may need to wait until Wednesday, but we'll see. I have a test board all ready to rock and roll, just got to find some old IDE cables, as all I seem to have ATM are SATA! So much for my big box 'o cables!

Pretty sure I have a dead PC in a dark cupboard somewhere that has spares. Getting into the cupboard, well that's another thing entirely!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: ST-IDE-ROM Dev Board v1 - BETA Testers

Post by PhilC »

I only have the PLCC socket for the CPLD left to do and I have all of the test equipment all ready lined up (in a pile on the floor) and ready to go.

MY TF534s are all assembled but not working yet, so you are safe RJ, as I'm preoccupied with that and the DIY at home.

I have some heat proof gloves if they are any use for you? :P
If it ain't broke, test it to Destruction.
Post Reply

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”