R_J Progress

Where Alpha builders can post pics and progress etc
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: R_J Progress

Post by PaulJ »

exxos wrote: Sun Oct 28, 2018 9:44 am Almost sad to see 70789 being butchered :cry:
It is kinda sad, that was one of the better 1040 boards, may it rest in peace. Had glitter possibilities to. I used a 70523-001 rev C. with no glitter possible. R_J did you use a soldering iron or hot air to remove the parts? I see you left the OPTO which is a good move. Enjoy the new board. :yay:
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10983
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: R_J Progress

Post by rubber_jonnie »

I tend to use a soldering iron with fluxed wick, and if needs be some liquid flux to help things along. I did use hot air on the sockets to pre heat the solder for wicking, but TBH I find these boards delaminate really easily when heated, so I try to avoid it. I have a desoldering iron too with a built in sucker that I use for heavy joints.

Not that it really mattered. In all honesty, I had tried to upgrade this board to 1MB as you can see from the sockets, but it just wasn't happy, and after buzzing out the sockets, there were so many failed data and address lines, plus there were floppy problems, I decided it should be my donor board, as repairs would have taken too long.

Consequently I haven't been over cautious with the removal of parts, so the board is definitely dead now, but the parts yield is good, I got 2 funky PLCC sockets out of it for blitter upgrades. :o

Saying that though, the PCB quality was way below what I've seen on other boards I've worked on, it was really susceptible to heat damage from the soldering iron, with vias failing under what would be normal soldering conditions. Maybe it was a duff board from the off, it arrived sporting bodge wires on the first 512k RAM, who knows?
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: R_J Progress

Post by PaulJ »

I figured it was something like that. I just ordered a hot air machine to give that a try. The Atari boards suck to remove parts on, I find the solder is extremely oxidzed and every case for me different. I use plenty of flux and solder wick in most cases. Sometimes I find that the solder sucker is works better..
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10983
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: R_J Progress

Post by rubber_jonnie »

PaulJ wrote: Sun Oct 28, 2018 3:23 pm I figured it was something like that. I just ordered a hot air machine to give that a try. The Atari boards suck to remove parts on, I find the solder is extremely oxidzed and every case for me different. I use plenty of flux and solder wick in most cases. Sometimes I find that the solder sucker is works better..
I also find that melting my own solder on is in some cases the only way to get the desolder process started. Hot air worked ok for the funky PLCC sockets actually, but you need to be really patient and not get too close to the PCB.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: R_J Progress

Post by PaulJ »

What temp do you use on the hot air?
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10983
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: R_J Progress

Post by rubber_jonnie »

PaulJ wrote: Sun Oct 28, 2018 3:37 pm What temp do you use on the hot air?
Hmm, now you're asking, I don't recall. I do recall that it needed a lot of patience before the board got hot enough for me to remove the PLCC sockets though.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10983
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: R_J Progress

Post by rubber_jonnie »

Good news, the last of my sockets arrived today, so I can crack on :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R_J Progress

Post by Icky »

rubber_jonnie wrote: Thu Nov 01, 2018 12:12 pm Good news, the last of my sockets arrived today, so I can crack on :)
Back in the game :) - Good luck.

I am quite missing all that assembly time I had on the board.
User avatar
rubber_jonnie
Site Admin
Site Admin
Posts: 10983
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: R_J Progress

Post by rubber_jonnie »

Looking forward to getting the build finished so I can apply the fixes and test!!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...
User avatar
exxos
Site Admin
Site Admin
Posts: 24182
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R_J Progress

Post by exxos »

rubber_jonnie wrote: Thu Nov 01, 2018 12:48 pm Looking forward to getting the build finished so I can apply the fixes and test!!
Have fun :) :thumbup:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “ALPHA USER BUILDS”