Video driver thoughts

All information relating to the Alpha plus all the WIP threads etc.
User avatar
PaulJ
Posts: 1568
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Video driver thoughts

Post by PaulJ »

Icky wrote: Mon Nov 26, 2018 11:42 pm
exxos wrote: Mon Nov 26, 2018 10:50 pm

Hot coco then bed for you me thinks ;)
Call me Mr McShaky Hands.

Got the board soldered it needs a clean up from all the flux but the harder I tried to keep a steady hand the worse it got.

Notice the small cap nearest the big ones and its wonky but has connectivity - I gave up on presentation skills.


IMG_3315.png


Now I'm going to get a hot coco Exxos.

Testing in the morning.
:thumbup: :thumbup: :thumbup:
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

I think this is a 5 storey building.

I count the main board DIL. A stack of 2 DIL's. The row of SILs and the socket for the shifter.

My PSU on stilts is still not tall enough. The jumper and connector are too high. I'll change them to be right angles as this will be enough to allow the PSU to go back in place.

IMG_3318.png
IMG_3318.png (405 KiB) Viewed 3322 times
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

Damn the 33R resistors R19, R23 & R30 are now under the monitor & floppy un-f*ck boards. A bit of fiddly work ahead me thinks.
User avatar
PhilC
Moderator
Moderator
Posts: 6049
Joined: Fri Mar 23, 2018 8:22 pm

Re: Video driver thoughts

Post by PhilC »

But more opportunity to hot snot later.

What do you need to do with the resistors?

Not progressed very far with mine as got given work to do.
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

Forgottenmyname wrote: Tue Nov 27, 2018 1:06 pm But more opportunity to hot snot later.

What do you need to do with the resistors?

Not progressed very far with mine as got given work to do.
The resistors are the entry point for RGB to the monitor socket. Need to patch the connector on the Video DAC board to these points.

I am putting in jumper leads so I can go back to the original design if needed
User avatar
PhilC
Moderator
Moderator
Posts: 6049
Joined: Fri Mar 23, 2018 8:22 pm

Re: Video driver thoughts

Post by PhilC »

Sounds like a plan, will follow your lead when back home later.
If it ain't broke, test it to Destruction.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

This is how I have jumpered the RGB lines. Taking the RGB and the 33R lines out to the top of the board. Yet to hot snot it to make it secure.

IMG_3322.png
IMG_3322.png (135.2 KiB) Viewed 3300 times

Top of the board I can connect the RGB lines together from the bottom of the board to continue as the original design or connect to the Video DAC board (connectors in pic on Video DAC board may not be right as I haven't checked the correct RGB out from the board)

IMG_3324.png
IMG_3324.png (515.13 KiB) Viewed 3300 times
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

First power on and we got a black screen when it should be white at boot then the desktop finally arrived it is almost there.

Am going to do a check over the board incase my soldering is rubbish etc

IMG_3327.png
IMG_3327.png (582.76 KiB) Viewed 3291 times
User avatar
exxos
Site Admin
Site Admin
Posts: 24083
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos »

Icky wrote: Tue Nov 27, 2018 5:24 pm First power on and we got a black screen when it should be white at boot then the desktop finally arrived it is almost there.

Am going to do a check over the board incase my soldering is rubbish etc
That is some funky stuff! Those jumpers should adjust the brightness...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
Icky
Site Admin
Site Admin
Posts: 4004
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky »

exxos wrote: Tue Nov 27, 2018 5:27 pm
Icky wrote: Tue Nov 27, 2018 5:24 pm First power on and we got a black screen when it should be white at boot then the desktop finally arrived it is almost there.

Am going to do a check over the board incase my soldering is rubbish etc
That is some funky stuff! Those jumpers should adjust the brightness...
Jumpers make no difference.

Am still going over my soldering and checking all the connections etc.
Post Reply

Return to “ALPHA DEVELOPMENT INFO”