PCB Build - Progress - Post your Pics here :-)

All information relating to the Alpha plus all the WIP threads etc.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by PhilC »

Cool, will wire up the 12v and put the ram in tomorrow.

Hopefully this has given the rest of you some confidence to take the next steps, :D
If it ain't broke, test it to Destruction.
User avatar
exxos
Site Admin
Site Admin
Posts: 24202
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PCB Build - Progress - Post your Pics here :-)

Post by exxos »

Forgottenmyname wrote: Fri Sep 14, 2018 10:32 pm wire up the 12v .
? Wire 12V to what ? Nothing actually uses 12V on the board other than the 12V pull up on the RGB port. (not sure if that's needed for scart switching)
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
troed
Moderator
Moderator
Posts: 913
Joined: Mon Aug 21, 2017 10:27 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by troed »

exxos wrote: Fri Sep 14, 2018 10:36 pm ? Wire 12V to what ? Nothing actually uses 12V on the board other than the 12V pull up on the RGB port. (not sure if that's needed for scart switching)
The ubeswitch uses the 12V pin on the monitor out.
User avatar
frank.lukas
Posts: 681
Joined: Fri Jan 19, 2018 11:52 am

Re: PCB Build - Progress - Post your Pics here :-)

Post by frank.lukas »

exxos wrote: Fri Sep 14, 2018 10:36 pm ? Wire 12V to what ? Nothing actually uses 12V on the board other than the 12V pull up on the RGB port. (not sure if that's needed for scart switching)
The +12V over a 1.2K Resistor are using for scart autoswitching.
User avatar
exxos
Site Admin
Site Admin
Posts: 24202
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PCB Build - Progress - Post your Pics here :-)

Post by exxos »

I wonder if 5v would work for scary...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
frank.lukas
Posts: 681
Joined: Fri Jan 19, 2018 11:52 am

Re: PCB Build - Progress - Post your Pics here :-)

Post by frank.lukas »

When you have a TV with Scart try it. Connect a Atari ST/STE to your TV and with the +12V the TV switch automatic when you power the ST/STE on to the right Scart Input.
User avatar
Icky
Site Admin
Site Admin
Posts: 4013
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: PCB Build - Progress - Post your Pics here :-)

Post by Icky »

Looking at SCART Wikipedia page if I am not mistaken Pin 8 the switch pin can have different voltages which also selects different aspect ratios.

https://en.wikipedia.org/wiki/SCART
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by PhilC »

I don't have access to a start tv at the moment, I'm using an NEC multisync VGA but do have a scart to HDMI adaptor, which I can use my HDMI to DVI lead I guess?

Will probably put the ram board in and then see what the current load it, if thats still OK, will likely plug my recapped PSU in and see what happens, ie 5v and 12v.

I'll report back with that later on, will get the scope out just in case.
If it ain't broke, test it to Destruction.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by PhilC »

Today so far.

Plugged my 4mb mmu type upgrade made by Exxos into the board with my bench power supply supplying just 5v and gnd.

Current draw is presently a stable 930ma and the only chips to even get slightly warm are the two ram chips on the mmu adaptor, maybe around 40C.

Still no display but I think that's down to the ubeswitch?

Will try the recapped power supply next.
If it ain't broke, test it to Destruction.
User avatar
PhilC
Moderator
Moderator
Posts: 6063
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by PhilC »

So, with the psu in place, no output to either my scart to hdmi or to the ubeswitch output. Will grab the scope and see what I can find.
If it ain't broke, test it to Destruction.
Post Reply

Return to “ALPHA DEVELOPMENT INFO”