Exxos v2 Falcon030 Clock Patch POST-installation issues.

Problems with your machine in general.
Post Reply
Posts: 4
Joined: Tue Nov 21, 2023 1:18 pm
Location: Athens

Exxos v2 Falcon030 Clock Patch POST-installation issues.

Post by falcon030gr »

Hello there!

I am new to the forum but I couldn't post any replies on the clock patch v2 thread, that's why I am creating a new thread, just in case anyone can help.

Long ago, I had purchased 2x F030 clock patch v2 boards from Exxos (purple ones). At some point I decided to do the patch on one of my Falcons. I had previously performed the 74LS08 variant but I wanted to get rid of the piggyback crazyness and install the Exxos's "tidy and neat" solution.

For the record, the specific Falcon is a rev. B and was working correctly with the previous "atari patch", just wanted to have a "cleaner" motherboard... After installing the patch by following the relevant instructions/images found on the forum, I tried to boot it up.

Atari logo, memory check, all seem to go well. However... keyboard is not responsive in any way. POWER and DRIVE leds are working correctly on the keyboard but anything else is dead.

Trying to boot with the multidiagnostics ROM cartridge (set to Falcon) is giving a red screen with white random pixels allover the screen and stops there (works on my other Falcons and STs). SEE picture below

falcon030-diagnostics-boot.jpg (575.68 KiB) Viewed 307 times

Diagnostics check and initialize the keyboard before starting so could be something with the keyboard circuitry, right?

So I will list what I have tried in order to isolate/fix the issue of non-responsive keyboard - Testing using a VGA monitor

1. EXXOS v2 patch soldered: Ex-Changing keyboards from STs/Falcons that work when plugged in other Falcons/STs, Exxos Falcon STRAM simm adapter, 2x different 4MB STD Atari Falcon boards: FAIL (unresponsive keyboard apart from the leds)
3. Desoldering Exxos patch and re-installing the "old" 74LS08 patch: FAIL (unresponsive keyboard apart from the leds)
4. Desoldering the "old" 74LS08 patch and doing the 74F04 "atari" patch: FAIL (unresponsive keyboard apart from the leds)
5. Desoldering the right ACIA (ST EF68B50P) and replacing it with a ST EF6850P on a socket (from STE): FAIL (unresponsive keyboard apart from the leds)
6. Soldering a socket, re-installing original ACIA and changing the GAL (U44) above from a working Falcon: FAIL (unresponsive keyboard apart from the leds)
7. Checking the soldering on the 8-pin kb adapter and right ACIA/GAL, all are good, still no keyboard and unable to boot with diagnostics rom cartridge.

I have ordered a few ST EF68B50P (the 2MHz version of the 1MHz EF6850P found on ST/E) and I will install a 2nd socket for the MIDI ACIA and change it as well soon. Is there a possibility that the GAL (U63) used to solder the patch onto could have a damage from continuous soldering/desoldering? Should I replace aLL 4 GALs as well?

The fact that it doesn't boot to diagnostings because of a faulty keyboard initialization could include some other faulty component in the keyboard circuitry? If yes, which ones??? Screenshot might look like a bad RAM but does the same with all Atari standard RAM cards and SIMM adapters I have tried. Remember, POWER and DRIVE keyboard leds are working correctly on all keyboards I connected. Same results while doing the above tests on an Atari SC1224 monitor (just in case errors occured by using the VGA).

Thanks in advance - Any kind of help would be greatly appreciated!
User avatar
Site Admin
Site Admin
Posts: 23220
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK

Re: Exxos v2 Falcon030 Clock Patch POST-installation issues.

Post by exxos »

Does pressing the reset button have any effect ?

I also suggest you upload some clear close-up images of your motherboard and how you have things installed.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Posts: 73
Joined: Tue Jun 11, 2019 11:23 am
Location: Ruislip

Re: Exxos v2 Falcon030 Clock Patch POST-installation issues.

Post by jwd »

take the motherboard out (can eliminate some shorting issues), unplug everything from the board (IDE, Floppy, keyboard) and no cartridges connected.

Only connect power (is that good?) and a TV using the modulator output (no monitor port use at this stage), to see if NVRAM is messed up, i had no monitor output or sometimes a screwy screen, but a TV showed a clear desktop.

Power on, it should go to desktop (albeit with no drive icons) after about a minute with horrible blueish desktop, does that work for you?

If you have removed the memory board make sure you give it a good spray with quality contact cleaner before putting back in.
Posts: 4
Joined: Tue Nov 21, 2023 1:18 pm
Location: Athens

Re: Exxos v2 Falcon030 Clock Patch POST-installation issues.

Post by falcon030gr »


Thanks for the recommendations! I will try them as soon as I find some spare time and let you know of the progress/results.

Many thanks!
Proud owner of the entire Atari STF/STFM/STE/MegaST/MegaSTe/TT030/Falcon030/C-Lab Falcon MK range, Atari Monitors and peripherals of all types. I also own a few consoles including the Atari2600 (Darth Vader) and the Jaguar64. A few A500's and an A1200 too ;)
Posts: 457
Joined: Mon Aug 28, 2017 11:22 pm
Location: Kosice, Slovakia

Re: Exxos v2 Falcon030 Clock Patch POST-installation issues.

Post by mikro »

A long time ago I had a similar issue: I was pretty careless and wrongly inserted the keyboard connector: it not only burned the ACIA but also one trace on PCB leading to it. So since then I have to live with an additional wire going to the keyboard ACIA. :) Lesson learned the hard way.

Also, as others mentioned, disconnecting the keyboard could give further hints.
Post Reply