Server updates

Latest Atari related news.
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Server updates

Post by exxos »

I may need to update the DNS again for IPv6 support. So we may go down again for a bit later.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
stween
Posts: 144
Joined: Sat Sep 08, 2018 3:10 pm
Location: Brooklyn & Edinburgh

Re: Server updates

Post by stween »

exxos wrote: Mon Jun 13, 2022 2:22 pm I may need to update the DNS again for IPv6 support. So we may go down again for a bit later.
Oh, you've dropped a link-local (fe80) address into the public record. A mistake? That will do no harm, but everything will ignore it because it's not globally routable.
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Server updates

Post by exxos »

stween wrote: Mon Jun 13, 2022 2:35 pm Oh, you've dropped a link-local (fe80) address into the public record. A mistake? That will do no harm, but everything will ignore it because it's not globally routable.
Have no idea what that means :)

I just added a AAAA record for the IPv6 .. I think..

https://www.123-reg.co.uk/support/domai ... main-name/

Apparently I am supposed to remove the v4 one... But I have a feeling everything will break if I do.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
stween
Posts: 144
Joined: Sat Sep 08, 2018 3:10 pm
Location: Brooklyn & Edinburgh

Re: Server updates

Post by stween »

exxos wrote: Mon Jun 13, 2022 2:38 pm
stween wrote: Mon Jun 13, 2022 2:35 pm Oh, you've dropped a link-local (fe80) address into the public record. A mistake? That will do no harm, but everything will ignore it because it's not globally routable.
Have no idea what that means :)

I just added a AAAA record for the IPv6 .. I think..

https://www.123-reg.co.uk/support/domai ... main-name/
Link-local is an address range which only operates on the local ethernet/wifi link; it won't be routed anywhere else. IPv6 network configs alway show the link-local address to you. But because it's locally scoped, it can't be used over the internet to reach your network from mine.

So it's redundant in that AAAA record; clients will get the record and immediately ignore it because they can't use it. They'll always select the A record instead.

If your host has another IPv6 address (it'll start with a 2), then that's your public one. Happy to test it before DNS changes, if you like. If your host doesn't have that, then it's not been configured with public v6.
Apparently I am supposed to remove the v4 one... But I have a feeling everything will break if I do.
If you do that right now, nobody will reach you. If you set up public v6 then remove the A record, you might lose 60% of your users :)
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Server updates

Post by exxos »

Not sure how to find the IPv6.. all the sites say something different :roll:

I think its 2a00:d880:11::243 so added that just..
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
stween
Posts: 144
Joined: Sat Sep 08, 2018 3:10 pm
Location: Brooklyn & Edinburgh

Re: Server updates

Post by stween »

exxos wrote: Mon Jun 13, 2022 2:55 pm Not sure how to find the IPv6.. all the sites say something different :roll:
Assuming linux or closely related, "ip addr list" or "ifconfig', will list inet6 addresses.
I think its 2a00:d880:11::243 so added that just..
Yup, that responds with exxosforum content.

Code: Select all

$ curl -H "Host: exxosforum.co.uk" http://[2a00:d880:11::243]
<html>
<head>
<title>EXXOS FORUM</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<meta http-equiv="refresh" content="0; url=https://www.exxosforum.co.uk/forum/index.php" />

</head>
<body>

</body>
</html>
Change your existing AAAA to remove the fe80 address, replace it with the 2a00 address, and I reckon you're done.
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Server updates

Post by exxos »

Not happy still for some reason.

Code: Select all

host aspmx.l.google.com[2a00:1450:4025:402::1b] said:
    550-5.7.1 [2a00:d880:11::243] Our system has detected that this message
    does not 550-5.7.1 meet IPv6 sending guidelines regarding PTR records and
    authentication 550-5.7.1 . Please review 550-5.7.1
    https://support.google.com/mail/?p=IPv6AuthError for more information 550
    5.7.1 . sa35-20020a1709076d2300b00712128834c2si8132567ejc.408 - gsmtp (in
    reply to end of DATA command)
This was trying to send a email to @IngoQ and also had the same problem with @terriblefire Though when I had the previous number in IPv6, @terriblefire emai seemed to then work :shrug:

https://mxtoolbox.com/SuperTool.aspx still reports the wrong number :roll:

Capture.PNG
Capture.PNG (23.93 KiB) Viewed 134 times

Guess i'll have to wait a bit ...
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
IngoQ
Site Admin
Site Admin
Posts: 1037
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: Server updates

Post by IngoQ »

The notifications worked, I guess they did a fallback to IPv4?

But the AAAA-Record is still unchanged, even if you query your hosters DNS directly:

host exxosforum.co.uk ns44.domaincontrol.com
Using domain server:
Name: ns44.domaincontrol.com
Address: 173.201.69.22#53
Aliases: 

exxosforum.co.uk has address 185.52.2.172
exxosforum.co.uk has IPv6 address fe80::f816:3eff:fe20:5ec0
exxosforum.co.uk mail is handled by 31 exxosforum.co.uk.

Ingo :geek:

| Atari 1040STE@32MHz | Amiga 1200 (ACA1220) | Atari 800XL (U1MB, SIDE2) | Atari 130XL (Sophia DVI) | C64 (1541 Ultimate II, Rev3 RFMod Replacement) | TI 99/4A (F18A, 32k, FlashROM 99) | Sinclair ZX Spectrum 128 (Stereo, DivMMC) | Amstrad CPC664 (512k, M4 Wifi) | ... |
User avatar
stween
Posts: 144
Joined: Sat Sep 08, 2018 3:10 pm
Location: Brooklyn & Edinburgh

Re: Server updates

Post by stween »

exxos wrote: Mon Jun 13, 2022 3:13 pm Not happy still for some reason.

Code: Select all

host aspmx.l.google.com[2a00:1450:4025:402::1b] said:
    550-5.7.1 [2a00:d880:11::243] Our system has detected that this message
    does not 550-5.7.1 meet IPv6 sending guidelines regarding PTR records and
    authentication 550-5.7.1 . Please review 550-5.7.1
    https://support.google.com/mail/?p=IPv6AuthError for more information 550
    5.7.1 . sa35-20020a1709076d2300b00712128834c2si8132567ejc.408 - gsmtp (in
    reply to end of DATA command)
Ah, mail. You do have a PTR record set up for that v6 address

Code: Select all

$ dig -x 2a00:d880:11::243 +short
exxosforum.co.uk.
But the page that google links to suggests they use other signals. I haven't gone digging further.

If v6 is a headache that you want to avoid for mail, you could consider putting mail on its own subdomain without any AAAA records. That pains my ipv6 heart, but I also hate doing mail ops.
Capture.PNG


Guess i'll have to wait a bit ...
I think your authoritative is still issuing the fe80 address. So either their revision control is extremely slow, or it didn't take when you tried to change it.
User avatar
exxos
Site Admin
Site Admin
Posts: 18652
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Server updates

Post by exxos »

For some reason it had reverted back to the previous old number :shrug:

I deleted it out and put it back in again and now I think it is okay ?
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Post Reply

Return to “NEWS & ANNOUNCEMENTS”