STE SOUND DAC CRACKLE & POP FIX

The latest tweaks and fixes to keep your machine running in tip-top shape.
Locked
User avatar
exxos
Site Admin
Site Admin
Posts: 18961
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

STE SOUND DAC CRACKLE & POP FIX

Post by exxos »

The original investigation had many twists and turns and can be seen in this thread. Fixes below have been proven to solve the problems of a small number of machines so far of varying motherboard revisions. But more testing needs to be done by more people.

You can use STE DMA SOUND TEST PROGRAM to diagnose the problem as shown in the video below.



A simple solution is to solder some wires as short and as direct as illustrated by the white wires in the image below. A typical 1amp hook-up wire is fine. It does not make any difference if it is solid or stranded. But should be of a reasonable thickness at least.

CRACKFIX.jpg
CRACKFIX.jpg (146.63 KiB) Viewed 311 times

The problem is mostly due to the bad usage of the 74F Series of logic chips. These are not good in noisy environments and actually cause noise due to their high switching currents. Also mix in Atari's typical poor grounding routing which compounds the issues.

Another proven fix Is to change them for a 74LS series chip.

One last proven fix is to lift the 5V power pin from the chip and connected back to 5V (from the cap) via a 40R resistor. For example.

IMG_0318.JPG
IMG_0318.JPG (316.25 KiB) Viewed 311 times

You might also be interested in the original STE DAC NOISE FIX mod as well. This mod helps to resolve the classic "whistling" problem in one of the STE audio channels.


Mirror of the test program from github.
ste_dmatest-1.0.zip
(28.21 KiB) Downloaded 6 times
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 18961
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STE SOUND DAC CRACKLE & POP FIX

Post by exxos »

I have moved posts to a new thread as this forum not a discussion forum.

viewtopic.php?f=29&t=5685
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
Locked

Return to “TWEAKS & FIXES”