MegaST ROM adapter - black screen

Upgrade or replace the ROM.
User avatar
HigashiJun
Posts: 1127
Joined: Fri Jun 19, 2020 7:21 am
Location: Tokyo

Re: MegaST ROM adapter - black screen

Post by HigashiJun »

There are also one or two bad solder joints on the top of the board...
User avatar
HigashiJun
Posts: 1127
Joined: Fri Jun 19, 2020 7:21 am
Location: Tokyo

Re: MegaST ROM adapter - black screen

Post by HigashiJun »

Badwolf wrote: Fri Feb 02, 2024 10:43 pm Start of January. It's not EPROM bitrot. I'm still using uncovered EPROMS from two years ago.

What I would suggest is putting the EPROM in the dualtos-equipped STFM I know Arti has to check the ROM is working and is the right one!

BW
It could have been January 2020... :lol:

Just kidding, but I had an EPROM which got blank after being left uncovered and exposed to daylight after much less than 2 years.
User avatar
arti040
Posts: 54
Joined: Wed Aug 24, 2022 7:09 am
Location: Poland

Re: MegaST ROM adapter - black screen

Post by arti040 »

Yea, previous ROMs, for STE, which @Badwolf prepared for me few months ago work fine in my exxos' STE adapter (which I have bought assembled by the way) so I presume, problem is in this MegaST one, which I assembled by myself. Checked all pins - everything is OK, I guess...
User avatar
Badwolf
Posts: 2214
Joined: Tue Nov 19, 2019 12:09 pm

Re: MegaST ROM adapter - black screen

Post by Badwolf »

arti040 wrote: Sat Feb 03, 2024 7:09 pm Yea, previous ROMs, for STE, which @Badwolf prepared for me few months ago work fine in my exxos' STE adapter
Oh, sorry -- I misremembered that it was an -FM.

BW
DFB1 Open source 50MHz 030 and TT-RAM accelerator for the Falcon
DSTB1 Open source 16Mhz 68k and AltRAM accelerator for the ST
Smalliermouse ST-optimised USB mouse adapter based on SmallyMouse2
FrontBench The Frontier: Elite 2 intro as a benchmark
Post Reply

Return to “ROM UPGRADES”