"Remember me" works only for a few days?

This chat forum will appear to guests and bots. IE will appear on search engines etc. If you do not want your appearing publicly then please use the original chat forum.
User avatar
stephen_usher
Posts: 5656
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: "Remember me" works only for a few days?

Post by stephen_usher »

OK, will do. Not that it's been a great hardship, merely a minor irritation at bed time.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.
User avatar
sporniket
Posts: 969
Joined: Sat Sep 26, 2020 9:12 pm
Location: France
Contact:

Re: "Remember me" works only for a few days?

Post by sporniket »

Hello, I occasionnally found myself logged off, two times this year at least. But I realized a few weeks ago, that appart from "exxosforum" domain name, Firefox kept some previous url to "exxoshost", given that I only type "ex" on the url field and then use one of the candidate served by Firefox...

To sum up, when I care to take the first url (to "exxosforum"), I am still logged in, but when selecting a link pointing to "exxoshost", I am logged out.
User avatar
exxos
Site Admin
Site Admin
Posts: 23705
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: "Remember me" works only for a few days?

Post by exxos »

sporniket wrote: Mon Apr 01, 2024 9:33 pm To sum up, when I care to take the first url (to "exxosforum"), I am still logged in, but when selecting a link pointing to "exxoshost", I am logged out.
I had a lot of problems with redirecting in nginx, in the end (in fact maybe 2 weeks ago) I just made exxoshost an alias and had done with it. Possibly up until then exxoshost/forum would likely have been a redirect to exxosforum.. but that would mean people haven't updated their bookmarks for like 2 years or something..

unfortunately, if anyone is using https://exxoshost.co.uk/forum/ it will not work with cookies as the forum uses exxosforum domain.

So everyone should always make sure to use the new url https://www.exxosforum.co.uk/

I am not aware of any links to forum posts with exxoshost ? Normally posts like that just take the url parameters.. unless there are "hardwired" posts on the forum to exxoshost/forum somewhere still ?

I did change all the https://exxoshost.co.uk/forum/ links to exxosforum some time ago.. but maybe there is something which got missed...:shrug:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
exxos
Site Admin
Site Admin
Posts: 23705
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: "Remember me" works only for a few days?

Post by exxos »

Can people try these links and make sure they all redirect to exxosforum..

https://exxoshost.co.uk/forum/
http://exxoshost.co.uk/forum/
https://www.exxoshost.co.uk/forum/
http://www.exxoshost.co.uk/forum/

https://exxoshost.co.uk/forum
http://exxoshost.co.uk/forum
https://www.exxoshost.co.uk/forum
http://www.exxoshost.co.uk/forum


For me on my PC, it's only redirecting WITH www in the URL... but on my tablet it seems to all work fine.. But I have been mislead by Chrome many times before.. So I think it's lying to me..

Again people need to use exxosforum.co.uk only. Exxoshost.co.uk/forum was discontinued 2 years ago now..
viewtopic.php?f=20&t=4299
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
TheNameOfTheGame
Posts: 164
Joined: Tue Dec 05, 2017 5:49 pm
Location: Almost Heaven, West Virginia

Re: "Remember me" works only for a few days?

Post by TheNameOfTheGame »

sporniket wrote: Mon Apr 01, 2024 9:33 pm Hello, I occasionnally found myself logged off, two times this year at least. But I realized a few weeks ago, that appart from "exxosforum" domain name, Firefox kept some previous url to "exxoshost", given that I only type "ex" on the url field and then use one of the candidate served by Firefox...

To sum up, when I care to take the first url (to "exxosforum"), I am still logged in, but when selecting a link pointing to "exxoshost", I am logged out.
Thanks, that fixed things for me.
User avatar
exxos
Site Admin
Site Admin
Posts: 23705
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: "Remember me" works only for a few days?

Post by exxos »

I left the forum logged in overnight and I am still logged in now.
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
User avatar
sporniket
Posts: 969
Joined: Sat Sep 26, 2020 9:12 pm
Location: France
Contact:

Re: "Remember me" works only for a few days?

Post by sporniket »

TheNameOfTheGame wrote: Tue Apr 02, 2024 2:22 am
sporniket wrote: Mon Apr 01, 2024 9:33 pm To sum up, when I care to take the first url (to "exxosforum"), I am still logged in, but when selecting a link pointing to "exxoshost", I am logged out.
Thanks, that fixed things for me.
My work here is done 8-)
User avatar
sporniket
Posts: 969
Joined: Sat Sep 26, 2020 9:12 pm
Location: France
Contact:

Re: "Remember me" works only for a few days?

Post by sporniket »

exxos wrote: Mon Apr 01, 2024 10:16 pm Can people try these links and make sure they all redirect to exxosforum..

(...)
Yes, I was redirect to index.php for all of them.
User avatar
exxos
Site Admin
Site Admin
Posts: 23705
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: "Remember me" works only for a few days?

Post by exxos »

sporniket wrote: Tue Apr 02, 2024 7:49 pm Yes, I was redirect to index.php for all of them.
:thanksyellow:
https://www.exxosforum.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxosforum.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~
People should find solutions to problems, not find problems with solutions.
mikro
Posts: 481
Joined: Mon Aug 28, 2017 11:22 pm
Location: Kosice, Slovakia
Contact:

Re: "Remember me" works only for a few days?

Post by mikro »

Changing bookmark to exxosforum.co.uk also helped for me.
Post Reply

Return to “CHAT FORUM PUBLIC”