Search found 11 matches

by wub
Tue Aug 02, 2022 9:30 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

Yeah, you're right. I wonder if that funky factory mod to the sound chip has something to do with it all..

Anyway, thanks for your advice! :)
by wub
Tue Aug 02, 2022 9:25 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

If you haven't tried the special Lotus Turbo STe version you're in for a treat! :) As for the chips, I found that they are all really tough to get out, so I let them be for now. I would have expected some sort of flaky behaviour, particularly when it warms up, if something like that was going on? I ...
by wub
Tue Aug 02, 2022 8:45 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

@exxos Thanks for the suggestion about replacing my CPU, I've looked at the ones you're selling and it sounds like a really good idea. I'll put an order in before the weekend!
by wub
Tue Aug 02, 2022 8:34 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

@Badwolf No, my STe is the same as this one: viewtopic.php?f=51&t=4718

The only difference is that the link on the bottom is flapping around freely as it doesn't have the blobs of glue holding it to the board.

Do you have problems running Lotus Turbo STe too?
by wub
Tue Aug 02, 2022 7:44 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

Hi again, sorry it took me a while to get back to you. I wanted to have the STe on for a really long time to see what happens when it gets proper hot. It was on for 10 hours continuously on Sunday and about 8 yesterday. As long as I don't load up Lotus Turbo STe then everything looks good. Thanks fo...
by wub
Sat Jul 30, 2022 12:23 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

Well, do I feel stupid or what! Firstly, my board is indeed a 5.1 rev model. The confusion was caused by the REV number being printed on the underside of the board in dark green and not on the top, where it explicitly says REV in big white letters. I assumed I had a REV 000 board and didn't examine ...
by wub
Fri Jul 29, 2022 11:39 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

Thanks for the advice, I'll do that!
by wub
Fri Jul 29, 2022 11:31 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Re: Strange STe link wire

Hi Exxos, yes, that's the version of motherboard I have. Edit: Ah, maybe not. I definitely don't have the REV 5.1 board, the REV level is blank on mine. Will it do any harm to add the link if I don't specifically have the 5.1 revision board? Either way I feel stupid for not looking at all the differ...
by wub
Fri Jul 29, 2022 11:05 pm
Forum: NOOB QUESTIONS
Topic: Strange STe link wire
Replies: 16
Views: 315

Strange STe link wire

I have the CA4003290 motherboard in my STe, the version with 2 wires coming off the sound chip and going to the piggybacked chips below the simm slots. I also have a single link wire on the bottom side of the PCB that is coming from the shifter but has come off from wherever it was going and is now ...
by wub
Fri Jul 29, 2022 10:09 pm
Forum: INTRODUCE YOURSELF
Topic: New user from the UK
Replies: 10
Views: 237

Re: New user from the UK

Thanks all! @Higgy The Sam is a lot of fun but, in hindsight, I don't feel I made the wrong choice going for an ST instead. They released Sam at least 2 years too late. Like you say, the Amiga was already on a different level to any 8-bit machine by then. The Sam has been more fun as an adult, with ...

Go to advanced search